BST not working on Chrome (only)

Device information:

  • Type of Mac: M1 MacBook Air
  • macOS version: 11.6
  • BetterTouchTool version: BetterSnapTool 1.9.5
  • Chrome Version: 94.0.4606.81

BST works totally fine on all applications, except Chrome. When I try to snap, it either resizes it but moves the window totally off the screen, or it just does nothing. Attached is a screenshot of what happens when I drag the Chrome window all the way to the left. The animation happens and it looks like it'll happen correctly, but it just goes off the screen.

have you already tried to restart your machine? sometimes the macOS windowing gets confused

Yeah, tried to restart and it didn't fix the problem. Same issue, Chrome buggy but nothing else.

weird, do you have any special chrome extensions installed?

Extensions I have installed:

Google Docs Offline
Privacy Badger

I have the same issues if I I use a guest profile.

if you haven't yet you could try to grant BST/BTT the screen recording permission (System Preferences => Security & Privacy => Privacy => Screen Recording). BST/BTT make use of an API for problematic apps ( - Great Tools for your Mac!)

Usually this is not necessary for Google Chrome, but it can help improve performance for all apps so in general I recommend granting this permission.

1 Like

I checked and I already had screen recording enabled.

I should also add that Chrome is managed by my employer I'm realizing, but only by name as far as I know, they don't have any restrictions. When I login on my personal chrome, left and right snapping works, but the top snapping has the same issue.

Does your employer maybe have some security software installed that's running on your Mac? I remember that there was one software that could break window snapping apps (but I haven't run into this for many years, so I don't remember which one)

No, they don't have anything additional on the Mac. They shipped it to me fresh from Apple and I haven't been asked to install anything.

(edit) The update to Monterey fixed this, yahoo!

Wanted to see if anyone else had any ideas. BST is pretty much unusable with Chrome, but that's the browser I use (and want to use) most often :sleepy:

UGH well updating to Monterey did fix this, but Chrome just updated to Version 95.0.4638.69 and it broke again in the same way. Does that bit of info help anyone figure out this bug?

very weird :-/
I wonder whether anything is special about chrome when it's managed. I will do some investigation into that.

I just realized I'm having the exact same issue with Firefox as well, so my title isn't correct anymore! Here's a video of me messing around with it in Chrome. In this demo I'm actually logged in under my personal account and don't have the "this account managed..." note.

Here's the same behavior in Firefrox. Mac, Firefox, Chrome and BetterSnapTool are all up to date.

in Firefox

I see, this is an old macOS bug where the window API doesn't do what it's supposed to do. That is usually fixed by restarting the machine once. However this should not appear as often as on your machine. I have encountered this behaviour maybe 5 times over the last 10 years :-/

Do you have any accessibility features or on-screen keyboards enabled on your machine?

Not that I know of. LastPass doesn't count as an on-screen keyboard, right?

Quick question: what is this app? image

iDrive backup, my backup app

@poppers it looks like Grammarly is causing this:

Oh perfect! We're 100% browser-based, so this shouldn't be too big of a deal because I can just use the Chrome extension. Thanks!