Big Sur issues - keeps popping up/disappearing

Hello! Just updated to Big Sur and it looks like BTT doesn't work anymore. When I click the app it just doesn't respond. This happened on the newest build, 3.504. I also downloaded 3.502 and when I click it, the symbol pops up in my menu bar but then disappears, and it does this sporadically. Any thoughts? Thank you!

Describe the bug
When starting the app, the menu icon appears for about 2-3 seconds (shortcuts are working for this time as well). After this time the app crashes.
There’s no crash when purging all BTT-related preferences via Finder.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar isn't launching at all, Keyboard Shortcuts are working for seconds

Device information:
Type of Mac: MacBook Pro 13" 2020 and iMac (Retina 5K, 27 Zoll, 2019)
macOS version: Big Sur 11.0.1
BetterTouchTool version: 3.502
Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

BetterTouchTool_2020-11-13-104452_DP-IMAC.crash (104.4 KB)

I can confirm this issue - here happens the same

sounds like this old issue: https://folivora.ai/blog/post/13010 try to follow the steps described there

Tried all options, but it is still not working.
It starts every now and then and I can see "BetterTouchToolAppleScriptRunner" in the Activity Monitor for a couple of seconds. And then its gone again.
Hope these details help to identify the issue

Extract from Console:
Nov 13 18:35:55 Uwes-MacBook-Pro com.apple.xpc.launchd[1]: Coalition Cache Hit: app<application.com.hegenberg.BetterTouchTool.38041472.38041478(501)> [691]
Nov 13 18:35:56 Uwes-MacBook-Pro com.apple.xpc.launchd[1] (application.com.hegenberg.BTTRelaunch.38041997.38042003[6031]): Service exited due to SIGTERM | sent by BetterTouchTool[6047]

I just tried that but it still doesn't work. Also, it looks like during the time BTT actually shows up in the menu bar, sometimes it darkens before disappearing, if that helps. Sometimes when it opens it will ask for privileges like it normally does when you first download it, but then it abruptly quits again.

Have you already tried to restart your Mac? (Stupid question but after macOS upgrades this often helps)

Oh and are you maybe all using some common preset that could cause the issue?

Restart is not helping - how can I modify my presets in the finder??
Attached is a log and the splash screen which is appearing.

com.hegenberg.BetterTouchTool 2020-11-13--18-19-17-556.crash (13.8 KB)

The most annoying thing at the moment is that I have no idea how to stop the tool from constantly reloading.

you can try to run this terminal vommand to put BTT in a safe mode:

defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled YES

The presets are saved in ~/Library/Application Support/BetterTouchTool, you could rename that folder to reset everything

Not sure if you suggested this necessarily, but I deleted the BetterTouchTool folder in application support and once I clicked the app again, it worked. Only been a few minutes so far but everything seems to seem good. Tried everything else and this was the only thing that worked. Thank you!

Ok, something else kind of interesting. I tried to re-register my account with my license, but as soon as I clicked my license and authorized it the issues started over again. I deleted the folder in application support again, reimported my custom settings, and now everything is working although it's still a "trial version" now. At least I have 45 days to figure it out...

I renamed the folder ~/Library/Application Support/BetterTouchTool and it starts now. I also copied in the license file from the renamed folder and it is registered now.
How can I import the setting from my old configuration to avoid reconfiguring everything. Where and how is it stored?
Thanks for your help.

could you send the content of the renamed folder to Andreas@folivora.ai? This might help me figure out the part of your config causes the crash. Then I should be able to fix it.

done!
Uwe

Are you sure it has been sent? I think I have not received it yet

As the crash report posted above suggests that the issue is caused by some missing permissions I have added all possible permission requests that could be triggered by some functionality in BTT to this alpha version: http://folivora.ai/releases/btt3.505-1643.zip

Would be great if you could check whether this still crashes for you.

1 Like

yes,I sent it, but from a different mail address - resent now again from the one used in that forum.
For me it makes no sense to check the alpha version as mine works now.

1 Like

now it arrived! I’ll have a look later today

@uschey I think in your case the crash was caused by missing bluetooth permissions. Apparently Big Sur needs to show the bluetooth permission warning before allowing BTT to use it. (And you have a bluetooth trigger in the "Other & Named Triggers" section)

I think this should be working again in v3.505, so you should be able to rename your renamed folder back to BetterTouchTool and delete the new one. http://folivora.ai/releases/btt3.505-1643.zip

1 Like
Imprint | Privacy Policy