BetterSnapTool not deleting custom snap areas

When I delete custom created snap areas, the snap region created stops functioning although the snap area still shows on screen as a snap region.

Type of Mac: MBP Touchbar (15-in, 2018)

  • macOS version: 10.13.6
  • BetterTouchTool version: 1.9.2

weird, do they also still appear when editing snap areas?

Lost also all custom snap areas. Deleting the new created one not working.

Also experiencing this problem. Can't delete snap areas. Using High Sierra 10.13.6

I'm also experiencing this issue on Catalina, choosing to delete any custom snap areas simply seems to have no effect whatsoever.

  • macOS Catalina version: 10.15.1
  • BetterSnapTool version: 1.9.2

Yes, the custom created snap area I have attempted to delete still shows when editing snap areas.

Same issue, cannot delete custom snap area... Running 10.14.6 Mojave

It seems to be some sort of data corruption issue.
It would be great if you could send me this folder:
~/Library/Application Support/BetterSnapTool/ (go there via Finder => Go => Go To Folder, make sure to include the ~). Then I can check what's going on. It seems to only affect some users thus I couldn't reproduce it yet.

You can also reset the snap areas completely by deleting this folder, after which they should work again correctly (but you'd need to set them up again).

I'm having the same issue with Catalina. Let me know if you want my BetterSnapTool folder and I'll send it.

Yes! It would be great to get it, then I can probably fix the issue :slight_smile:

BetterSnapTool.zip (9.4 KB)

Here you go

Same for Me! Thanks!

Imprint | Privacy Policy