BetterSnapTool not deleting custom snap areas

When I delete custom created snap areas, the snap region created stops functioning although the snap area still shows on screen as a snap region.

Type of Mac: MBP Touchbar (15-in, 2018)

  • macOS version: 10.13.6
  • BetterTouchTool version: 1.9.2

weird, do they also still appear when editing snap areas?

Lost also all custom snap areas. Deleting the new created one not working.

Also experiencing this problem. Can't delete snap areas. Using High Sierra 10.13.6

I'm also experiencing this issue on Catalina, choosing to delete any custom snap areas simply seems to have no effect whatsoever.

  • macOS Catalina version: 10.15.1
  • BetterSnapTool version: 1.9.2

Yes, the custom created snap area I have attempted to delete still shows when editing snap areas.

Same issue, cannot delete custom snap area... Running 10.14.6 Mojave

It seems to be some sort of data corruption issue.
It would be great if you could send me this folder:
~/Library/Application Support/BetterSnapTool/ (go there via Finder => Go => Go To Folder, make sure to include the ~). Then I can check what's going on. It seems to only affect some users thus I couldn't reproduce it yet.

You can also reset the snap areas completely by deleting this folder, after which they should work again correctly (but you'd need to set them up again).

I'm having the same issue with Catalina. Let me know if you want my BetterSnapTool folder and I'll send it.

Yes! It would be great to get it, then I can probably fix the issue :slight_smile:

BetterSnapTool.zip (9.4 KB)

Here you go

Same for Me! Thanks!

Hi,
I've just started using this fine product and have the same issue - can not delete the areas.

But when I tri to delete an area, all the areas stop working like the should.

Here is a short video showing it.

It's a big monitor - Dell U4919DW.

Here are the files you would like to see.

I think I might finally have identified the issue that caused this in some situations.
Could somebody check whether this beta version fixes the issue for you?
https://bettertouchtool.net/releases/BetterSnapTool_1_9_3_beta.zip

If it works I'll submit it to the App Store asap.

Hi

It do not work on my machine.
See short video.

There was no active window in my last video - sorry.
But see this bug when trying to create a new area.

When will there be a fix for this issue?

Did you try to edit and delete the snap areas? From your video it looks like there is just another old area at the exact same location.

Hmmm - I did the test ones more and now it all work like it should :slight_smile:
Release!

1 Like

Hi! i had the same problem but with this beta version it's working again. Thank you

Imprint | Privacy Policy