Anyone having issues with pinch to zoom?

The pinch to zoom option in the Mac system preferences occasionally turn off,
and I was wondering if others were having the same issue.
I haven't isolated the problem enough to be sure that BTT is the cause, but it happens on both my 2017 MacBook Pro and 2017 iMac running BTT.
It started happening around the time the multi finger gesture to 'show desktop' bug was fixed, if anyone remembers that.

1 Like

same here
I have to disable the BTT at the moment because of this

Could you post a screenshot or export of the gestures your have configured in BTT (if any)? Does it stop working in all apps?

yes, stopped working in all APPS

in your screenshot you have essentially disabled pinching for the Magic Trackpad 2 by assigning no action. Is this intentional?

not really, but tried everything I could
what's your suggestion ? what/how to set ?

I don't have much trackpad gestures on.
The tip tap gesture is something that I added about a couple of weeks ago, and the pinch to zoom started turning off months ago. :grimacing: The gestures and triggers are synchronized across all Macs using Dropbox.

try deleting the pinch gestures from your setup

Hello. Pinch to zoom occasionally turns off. I've noticed this problem as well and haven't noticed any patterns. In order to fix it, I restart BTT and toggle System Preferences -> Trackpad -> Zoom in or out. I have application specific gestures that involve pinching/spreading. Any help would be much appreciated.


Same here. Does smart zoom (tap twice with two fingers) keep on working for you?

Smart zoom continues to work for me, but pinch zoom stops working for me every few days and has to be reset via system prefs.


Pinch to zoom and rotate occasionally stop working.

When this happens, the option is on in the Sys Prefs even though its not working.

Switching the preference off and on again fixes it up fine, but the issue comes back once in a while.

I don’t have any trackpad gestures apart from a top right corner click.

I also have this bug.

In order to fix it I have to switching the trackpad geasture off and on again in sys pref or just start this command and wait pmset displaysleepnow; sleep 5; caffeinate -u -t 1.

I think that this issue occur more when I have a high CPU activity.

Yes, the same happens to me very frequently even though I don't in fact have pinch gestures configured in BTT.

I'm fairly sure I know what triggers it though - this appears to happen sometimes after window snapping with the trackpad.

There is also a fix which I find easier then enabling / disabling the gesture in settings. I simply put the computer to sleep and wake it up again.

Unfortunately it turned out this is a known issue with CGEventTaps on macOS (an API BTT and various other apps need to function). There currently doesn't seem to be a way to prevent this.

It seems to happen when macOS is busy and skips an event. I'll post another bug report to Apple about this.

In general remove all 2 finger pinch or rotate gestures from BTT, but that doesn't seem to fix it completely unfortunately.


Ahh! Thanks Andreas, good to know. At least we know where it's coming from.

I do have 2-Finger rotate actions. I'll test to see if it's worth disabling them.

Hi Andreas,

Do you know if this issue has been fixed on macOS Catalina?

This used to happen on my system only occasionally, but more recently it has been happening all the time. Pinch to zoom and 2-finger swipe (e.g. in Mail to delete a message) break. Sleeping for an instant and then waking back up fixes it, but a little while later it breaks again. It happens several times a day.

I don't know if the issue is related to BTT or if it's just a macOS bug, but it's driving me nuts!

Thanks for any info.

1 Like

It persists on the latest Public Beta.
One these days I'm gonna try the terminal solution @Andreas_Hegenberg posted in another thread.

What terminal solution are you talking about? Couldn't find the thread you are mentioning. This bug has been plaguing me for a year or more and so I'd love for this to be solved.

defaults write com.hegenberg.BetterTouchTool BTTAutomaticallyRefreshPinches YES

Find the whole topic here, including a Touchbar button to fix it.