Anyone having issues with pinch to zoom?

trackpad
#1

The pinch to zoom option in the Mac system preferences occasionally turn off,
and I was wondering if others were having the same issue.
I haven't isolated the problem enough to be sure that BTT is the cause, but it happens on both my 2017 MacBook Pro and 2017 iMac running BTT.
It started happening around the time the multi finger gesture to 'show desktop' bug was fixed, if anyone remembers that.

1 Like

#2

same here
I have to disable the BTT at the moment because of this

0 Likes

#3

Could you post a screenshot or export of the gestures your have configured in BTT (if any)? Does it stop working in all apps?

0 Likes

#4

yes, stopped working in all APPS

0 Likes

#5

in your screenshot you have essentially disabled pinching for the Magic Trackpad 2 by assigning no action. Is this intentional?

0 Likes

#6

not really, but tried everything I could
what's your suggestion ? what/how to set ?

0 Likes

#7

I don't have much trackpad gestures on.
The tip tap gesture is something that I added about a couple of weeks ago, and the pinch to zoom started turning off months ago. :grimacing: The gestures and triggers are synchronized across all Macs using Dropbox.

0 Likes

#8

@michael
try deleting the pinch gestures from your setup

0 Likes

#9

Hello. Pinch to zoom occasionally turns off. I've noticed this problem as well and haven't noticed any patterns. In order to fix it, I restart BTT and toggle System Preferences -> Trackpad -> Zoom in or out. I have application specific gestures that involve pinching/spreading. Any help would be much appreciated.

Thanks!
J.C.

0 Likes

#10

Same here. Does smart zoom (tap twice with two fingers) keep on working for you?

0 Likes

#11

Smart zoom continues to work for me, but pinch zoom stops working for me every few days and has to be reset via system prefs.

0 Likes

#12

+1

Pinch to zoom and rotate occasionally stop working.

When this happens, the option is on in the Sys Prefs even though its not working.

Switching the preference off and on again fixes it up fine, but the issue comes back once in a while.

I don’t have any trackpad gestures apart from a top right corner click.

0 Likes

#13

I also have this bug.

In order to fix it I have to switching the trackpad geasture off and on again in sys pref or just start this command and wait pmset displaysleepnow; sleep 5; caffeinate -u -t 1.

I think that this issue occur more when I have a high CPU activity.

0 Likes

#14

Yes, the same happens to me very frequently even though I don't in fact have pinch gestures configured in BTT.

I'm fairly sure I know what triggers it though - this appears to happen sometimes after window snapping with the trackpad.

There is also a fix which I find easier then enabling / disabling the gesture in settings. I simply put the computer to sleep and wake it up again.

0 Likes

#15

Unfortunately it turned out this is a known issue with CGEventTaps on macOS (an API BTT and various other apps need to function). There currently doesn't seem to be a way to prevent this.

It seems to happen when macOS is busy and skips an event. I'll post another bug report to Apple about this.

In general remove all 2 finger pinch or rotate gestures from BTT, but that doesn't seem to fix it completely unfortunately.

4 Likes

Safari swipe-back default macOS gesture stops working
#16

Ahh! Thanks Andreas, good to know. At least we know where it's coming from.

I do have 2-Finger rotate actions. I'll test to see if it's worth disabling them.

0 Likes