3-finger tap not working for middle click.

Describe the bug
I set '3 Finger Tap' for action 'Middle Click' but it doesn't work in Chrome.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
I use trackpad of Macbook.


Device information:

  • Type of Mac: Macbook Pro Retina 15" early 2013
  • macOS version: MacOS High Sierra 10.13.6
  • BetterTouchTool version: 2.646
    Please support to check again, looking for your feedback soon.
    Thanks a lot!

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

I have a similar problem. I have 3 finger click set for middle click and it works correctly in terminal.app where I use it to paste selected text but is not working in xquartz.app where I have a gui forwarded from a remote server. This was working perfectly with a Magic Trackpad 1 but today I switched to a new Magic Trackpad 2 and it is not working. I switched back to the old trackpad and it is working perfectly. It seems that something needs to be adjusted for the Trackpad 2 to work.

Affected input device is Magic trackpad 2

Device information:
Late 2013 iMac
MacOS High Sierra 10.13.6
BTT version 2.660

Had the same issue. The "bug" is connected to the OSx Trackpad Settings. Just change it to a gesture (everything besides 3 fingers). For further discussion look here: ThreeFingerClick to Middle Click not reliable, when Tap To Click is enabled in OSx Setting

Hi Konti,
Thanks for the info, unfortunately it does not help my issue. I have tap to click and Look up & data detectors tap with three fingers disabled in System Prefs. I have also tried various other gestures to act as middle click without success in XQuartz and a Magic trackpad2. I don't think I explained the issue too well in my previous post so:

I use a piece of scientific software (COOT) which runs on our servers it displays 3D atomic co-ordinates of protein molecules. I ssh -XY into the server to use the software with X forwarding and so the COOT gui runs in an XQuartz window. I need middle click on my input device to centre the view on a particular atom. I have used BTT and Magicprefs to replicate middle click for this purpose on a Magic trackpad 1 successfully for several years. I got a new Magic trackpad 2 this week and discovered that MagicPrefs did not support this model and so I bought a new licence for BTT which had worked well in the past. Having installed the latest BTT and checked my settings were still correct (i.e use three finger click to replicate middle click), I discovered that this functions correctly in local Mac apps, it does not work in COOT via the XQuartz window. So for example, I can cut and paste text in Terminal.app by selecting text and middle clicking, with the text being pasted at the cursor as expected and in Safari, middle clicking on a link opens in a new tab. However, in the COOT/XQuartz window, middle click does not work. I tried several different gestures including using keys in addition to a gesture and got the same effect. It works in the other software but not in the COOT/XQuartz window. I had made the setting in Global but to be sure I made a specific setting for XQuartz and got the same issue. I then disconnected the trackpad 2 and reconnected the track pad 1. Three finger click as middle click worked in all apps. So this does seem to be a specific problem with the Magic trackpad 2. After reading your post I have just tried modifying the settings again to use something other than three finger click just to be sure. I checked that Tap to click and Look up & data detectors are off in System Prefs and then I set BTT to 2 finger click plus shift key for middle click.

With the Magic Track Pad 1, it works in terminal and safari and in COOT/XQuartz.
With the Magic Track pad 2, it works in terminal and safari but does not work in the COOT/XQuartz window.

I then tried adding other keys to the gesture to hopefully make it unique and got the same result.
I have also installed a local version of COOT and again the Magic Trackpad 2 does not "middle click" in the XQuartz window yet the Magic Trackpad 1 is working perfectly.

I have reverted to the Magic Trackpad 1 but it would be nice if BTT could work in COOT/XQuartz with the Magic Track pad 2 as that allows for more gesture control in other apps.



1 Like

Sorry for not being able to help out. Hope somebodyelse can help you!

I have found a way to get middle click to work in XQUARTZ with a Magic Trackpad 2. Bizarrely, the Trackpad2 works as it should if you have the XQUARTZ preferences window open. If you close the preference window, middle click is no longer recognised in the XQUARTZ window running COOT. There are 4 tick boxes in the INPUT section but only one (enable key equivalents under XQUARTZ) was ticked. There is an option in the XQUARTZ preferences to emulate middle click. This was unticked as default. I tested ticking this button and closing the preference window. No middle click gesture is recognised. If you open the Preferences again, it works. Any one know why having the Preferences window open makes a difference?