ThreeFingerClick to Middle Click not reliable, when Tap To Click is enabled in OSx Setting

Describe the bug
A clear and concise description of what the bug is.

ThreeFingerClick to Middle Click not reliable, when Tap To Click is enabled in OSx Setting. Sometimes opening a new Tab in Safari works, but sometimes another tab is being opened and sometimes the site is being opened directly with the middle click.

If I want to make it work 100% I need to

  1. Go to the link
  2. Put my three fingers on the trackpad
  3. Wait half a second until they get recognized
  4. Then Three finger click

What doesn't work well.

  1. Go to the link
  2. Directly Three finger click(without putting the 3 fingers on the trackpad and waiting half a second)

--> This causes problems in the 2-6 link I am clicking in Safari to let it open in a new tba.

However when the OSx Setting "Tap to click" is disabled the Middle Click with ThreeFingerClick to open Links in Tabs in Safari seems working fine. In this mode I can directly 3-Finger Click on the links (without waiting after putting my 3 Fingers on the trackpad) without any issues. But Iam highly dependent on the tap to click feature, so I cannot disable it to get a better middle click experience.

This is very annoying. On my old Macbook 2011 without the force to touch trackpad I had no problems middle clicking on links to open them in tabs with the same settings, while the tap to click feature was enabled in OSx.

This problem has been described also in the previous GitHub forum: (

A fix would be great, because it is very frustration and I am right now more fast with using command key and tapping the link.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Macbook Pro Retina Mid 2015, 15" Force To Touch Trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro Retina Mid 2015, 15" Force To Touch Trackpad
  • macOS version: OSX Sierra 10.12.6
  • BetterTouchTool version: 2.530

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Do you only have tap to click enabled or also the three finger dragging?

Yes! Three finger dragging in the accessibility is also enabled. (same like on my old mbp pro 2011)

Unfortunately on the newer models three finger dragging is hard to support. You can try to change the "three finger drag" option in the advanced trackpad prefs and see whether that works better for you:

What I learned so far

  1. Tap to click and also the three finger dragging (in the OSX preferences) enabled = middle click on links for tabs is still unreliable

  2. Tap to click and also the three finger dragging (in the OSX preferences) enabled and optimize 3 finger finger drag in BTT - middle click on links for tabs is still unreliable (So the suggested solution from you Andreas does not work.)

  3. Tap to click disabled but the three finger dragging (in the OSX preferences) enabled = middle click on links for tabs works reliable!

  4. Tap to click enabled and the three finger dragging (in the OSX preferences) disabled = middle click on links for tabs works reliable!
    (when the two settings above are enabled it also works fine)

So actually to make the middle click more reliable and to have all the functions: It would be nice to disable the three finger drag in OSX, while still having the ability to create this feature n BTT.

So is it possible to enable three finger dragging directly in BTT? Then my problem would be fixed!

You know what. I just changed my workflow: From now on the middle click is simulated by a two finger click. This solves all problems and I can use my beloved three finger drag and open in tabs (with a two finger click) without any problems. Lets keep working. Loving but and my force to touch trackpad. (there is always a solution :))

Still I would hope to fix that issue with the three finger click and the conflict with apples three finger dragging and one finger tap to clicking. Then I could switch back to my old workflow of the past 6 years.

Short story: Just keep Three Finger Dragging in OSX preferences enabled and DONT USE THREE FINGER CLICK GESTURE in BTT. Rather us ANY OTHER FINGER CLICK (LIKE TWO, OR FOR FINGER) in BTT. Otherwise three finger drag will have a conflict with BTT three finger click!

I also had this issue with MiddleClick.

I haven't tried BTT.

I use MagicPrefs to get around the issue:

  1. Switch off "Tap to click" in your Mac's Trackpad settings.
    Then, in MagicPrefs:
  2. Activate and choose function for "x Fingers Tap" as desired.
  3. Adjust "Gesture Triggering" and "Edit the zone of the gesture", [I had to do this as it was causing keyboard to act up as if a ctrl or other similar key was been held, e.g. perhaps best not to maximise the response zone of your trackpad, or set too high a sensitivity in gesture triggering].
  4. You may have to "Allow" MagicPrefs in Security & Privacy > Accessibility.
  5. MagicPrefs is no longer maintained, so may not work properly or at all in more recent versions of macOS [I'm using High Sierra on a MacBook Air (Late 2010)].


I'm also having this problem, and it's the main thing keeping me from buying BTT -- I can't seem to get a workflow where both tap to click, and three-finger middle click (or cmd+click) are both working reliably and never mistaken for one another, while three-finger drag is also enabled. It would be great if this were fixable but I understand it's probably really tricky.

I had the exact same issue, middle click is not reliable on trackpad, the only fix i've discovered is to disable Tap To Click in System Preferences like the friend opened this issue. This is so annoying me.

See above, disabling three finger dragging usually fixes all Three Finger Tap / Click issues. Unfortunately there is no other workaround because enabling the three finger drag changes some fundamental behaviors of the trackpad and prevent BTT from intercepting some of the events early enough.

1 Like

[macOS Mojave 10.14.6 / BTT 3.186 / Magic Trackpad 2]

I was using MagicPrefs in conjunction with Menu Mate to control my multi-finger clicks, but it was not accurate in distinguishing how many fingers I was using. So I bought BTT thinking this would solve my problem. Nope.

When I first installed BTT on July 2nd, the 3-finger click for middle click worked occasionally with no observable pattern. Now it doesn't work at all. I've tried every suggestion on this and similar posts with no luck. I even set it to display when the 3-finger click was triggered, and it registered properly but still didn't do a middle click. So with high hopes I swapped the actions of 3-finger and 4-finger clicks, but then the 4-finger click (middle click) didn't work while the 3-finger one did. Go figure. It seems that, for me, nothing triggers a middle click, which, again, is one of the main reasons I bought BTT. It seems like this has been a problem for years. Any ideas?

Do you have three finger dragging enabled? (see above post).

Believe me, I've tried every setting (on and off) mentioned in three threads. 3FingerDrag is off, but I assume that shouldn't have mattered when I switched to 4FingerClick.

Enabling three finger drag changes some fundamental behaviors of the trackpad, thus it affects multiple gestures.

However if that doesn’t help I don’t know :-/ three finger taps are by far the most used gesture in BTT and should be pretty reliable. Maybe try to reset your BTT settings?

(to completely reset, delete ~/Library/Application Support/BetterTouchTool and ~/Library/Preferences/com.hegenberg.BetterTouchTool.plist )

Doh! I've been a power user since the DOS days and am now convinced that I'm suffering from a condition called OLD :frowning_face:.

I just tested middle click on a link and it works as the OP described. The reason I was confused is because I've never used middle click for that. Instead, I used it to activate MenuMate which converted it to open the active app's menu wherever my cursor was so I didn't have to go up to the menu bar to click it. The reason why that didn't work using BTT's middle click was because forgot I had uninstalled MenuMate recently assuming it was only 32-bit since it hasn't been updated in three years (turns out it's 64-bit). It's hard to isolate the variables when you've forgotten what some of them are.

So my apologies for all the drama. I think I'll move along now :wink: .

I can't find anything about a 3-finger drag in the system preferences nor BTT. I've turned off all 3 finger system preferences and BTT doesn't work for middle click.

Three finger drag is in system preferences => accessibility => mouse & trackpad => trackpad options