Your BTT touch bar is hidden, click to show

Every time I wake up my laptop after sleep I have to click "Your BTT touch bar is hidden, click to show" to make my BTT visible. That's very annoying and I though it's some kind of trial limitation (however I didn't have this during the previous couple of weeks), so I bought the license. Unfortunately nothing has changed: it's still hidden every time I restart the app.
My system preferences touch bar setting is already set to "App controls".
I want my BTT to be permanently visible, without any annoying clicks to toggle it. How do I disable this feature?

MBP 16
Mac OS 10.15.2
BTT 3.270


It looks like 3.332 has fixed this for me. Thanks!

1 Like

Sadly I just woke my 16" MBP the next day (ie today) and it was hidden again. Damn it, not fixed. :frowning:

on some systems it might be necessary to increase the touch bar show delay in the advanced Touch Bar settings. (v3.332)

In general I recommend to just set a keyboard shortcut to toggle the BTT Touch Bar (and/or enable to show the BTT icon in the control strip) as it might get hidden by the system for various reasons.

I'll give the delay a try. I'm curious what you mean by "some systems" and what the differentiating factors are between it working and not working. I know Apple do some head scratching things, sometimes.

Creating a shortcut isn't an adequate solution for me, when it's been working fine for years without it! Thanks for the suggestion though, Andreas. Hopefully you can get to the bottom of it soon and we can return to paradise. :slight_smile:

As far as I know it's mostly a timing issue, on most systems it seems to work fine, on some something introduces a delay which causes the Touch Bar to unhide at the wrong time. This is mostly happening since macOS Catalina.

There might not be a real solution because nothing of this is officially supported. Apple doesn't want custom Touch Bars like BTT provides.

But toggling it looks kinda weird.
If btt knows, that it's hidden why it can't make itself visible again?


I've been having the same problem over the course of about the past week. I've been using BTT since last fall and I haven't run into this problem until just now. Any help would be greatly appreciated.

Usually it helps to set a little after sleep init delay in the advanced Touch Bar settings in BTT.

1 Like

How much delay would you recommend? :slight_smile:

0.2 should be enough :slightly_smiling_face:

Thank you, it worked perfectly

This problem appeared repeatedly today (after months using it without issues). Added the delay as per above, and it seems fine. Still surprised about what could have changed.