Won't launch after update

First post. Thanks Andreas for such a wonderful & essential tool.

Got an update notification just now, so I clicked "update". After the update, BTT just won't launch. I've tried a) deleting & re-adding permissions; b) reinstalling, and c) rebooting. Won't work.

I then tried opening the executable by hand, and here's the traceback:

alan@Alans-Mac-mini ~ % /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool ; exit;
2021-10-24 13:34:35.088 BetterTouchTool[2787:207843] -[SBObject icon]: unrecognized selector sent to instance 0x6000000f6310
2021-10-24 13:34:35.088 BetterTouchTool[2787:207843] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SBObject icon]: unrecognized selector sent to instance 0x6000000f6310'
*** First throw call stack:
	0   CoreFoundation                      0x00000001bfa3f150 __exceptionPreprocess + 240
	1   libobjc.A.dylib                     0x00000001bf7906e8 objc_exception_throw + 60
	2   CoreFoundation                      0x00000001bfad1f80 -[NSObject(NSObject) __retain_OA] + 0
	3   CoreFoundation                      0x00000001bf99f600 ___forwarding___ + 1728
	4   CoreFoundation                      0x00000001bf99ee80 _CF_forwarding_prep_0 + 96
	5   BetterTouchTool                     0x0000000104767794 __31-[BTTActions loadShortcutIcons]_block_invoke + 288
	6   libdispatch.dylib                   0x00000001bf733e14 _dispatch_call_block_and_release + 32
	7   libdispatch.dylib                   0x00000001bf735b80 _dispatch_client_callout + 20
	8   libdispatch.dylib                   0x00000001bf747560 _dispatch_root_queue_drain + 676
	9   libdispatch.dylib                   0x00000001bf747c7c _dispatch_worker_thread2 + 168
	10  libsystem_pthread.dylib             0x00000001bf8f04ec _pthread_wqthread + 228
	11  libsystem_pthread.dylib             0x00000001bf8ef208 start_wqthread + 8
libc++abi: terminating with uncaught exception of type NSException
zsh: abort      /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool

Finally, I replaced the app with an older version (3.560) from another Mac, and it's now working as usual.

I haven't got time to check the forum thoroughly to see if this problem has occurred before to anyone else (my apologies). But I thought I should just report this so you can check if it's really a bug or some silly mistake on my part.

M1 Mac mini btw.


that’s weird, which version of macOS are you running on this machine? The error code should only be executed while running macOS 12 Monterey .

Thanks for reporting!

Ah you might have an outdated beta of macOS Monterey running, is that possible? I think Apple fixed a bug related to the icon property that is mentioned in the error message a while ago. Unfortunately I can not check for specific beta versions, but it should be fixed after you upgrade to the release candidate.

I am having a similar issue except when I go to an earlier version it still doesn't open.

can you post the crashlog? (macOS console app -> crash reports or user diagnostic reports)

If you are on a macos Monterey beta, make sure to upgrade to the latest.

The crash report is over 99000 character-wise so it won't post.

can you send it to andreas@folivora.ai?

I'm facing the same problem. Tried to go to an earlier version and it still doesn't open. I'm using mac m1 on mac os 12 latest beta

i can't use BTT anyway, yesterday i updated my macos in monterey 12.0.1(this is the newest version) and the BTT was like that

It actually works now for some reason.

Sorry for the delayed reply. Indeed I have an outdated Monterey beta running! Thank you Andreas!