Window Snapping not working

I installed the newest update (3.04; 1163) and window snapping no longer works. Have tried restarting, disabling and re-enabling, to no avail.

iMac Retina 27-inch Late 2014 running Mojave 10.14.5 (18F132).

There hasn't been a change to window snapping as far as I can tell.
Is window snapping still enabled in the BTT settings?
Could you try the steps described here? https://folivora.ai/blog/post/13005

Yes, it is enabled. I tried those steps, and neither worked. Are there further steps I can try?

have you tried restarting the complete system or just BTT?

I'm having the same issue here. Generic snapping (like moving to the top of the screen) is still working, but my custom snapareas are not working and i cannot define new ones.

That's probably something else.
Are you sure snap areas are not disabled?

1 Like

Thanks a lot, that helped! I imported Golden Chaos addon and it somehow disabled this setting. i tripplechecked all the other options, but missed that one (and the required restart). now it works again.

Mine is working again. Somehow after I came back after the computer had gone to sleep it asked again to update permissions within Accessibility. Once I enabled, I could snap windows again. I'm not sure what happened because it has already been enabled before.

Window snapping is broken for me too on my iMac

Probably also after I had Golden chaos imported on my Mac book pro. Sync is turned on.
Snapping works on the MacBook, but not on iMac.

Snap areas are not disabled.
Restart didn't help either.

Any ideas?

Does this screen show everything enabled?

Yes, they are all enabled.

In the meantime I reapplied all the security settings in system preferences, did a restart and..... Voila, it works again.

Strange nevertheless.....

r.

I'm also having this problem.... I've tried restarting btt, enabling and disabling, checking accesibility preferences, etc. and nothing is working.

You also imported the Goldenchaos preset? It's probably some setting in there, but I don't know which.
You can always reset to the defaults by quitting BTT and executing this terminal command:

defaults delete com.hegenberg.BetterTouchTool

Same issue here. Suddenly the snap feature stopped working. Keyboard shortcuts don't work either for window resize.
What I have tried

  • Reset SMC
  • Restart BetterTouchTool
  • Reset accessibility settings

None seemed to help

Using macOS Mojave 10.14.3 with external displays.

Is BetterTouchTool still enabled for you?
image

1 Like

I had the same window-snapping problem reported above here, with none of the listed suggestions helping. I don't use the menubar icon and had it turned off. Andreas' suggestion prompted me to turn it on and there I discovered that BTT was disabled.

Enabling BTT via the menubar button fixed all of the non-response on both my iMac and my MacBook Air. I suspect one of the recent updates disabled BTT and it takes the menubar button to re-enable it.

Hope this helps

1 Like

This fixed my issue. Thank you very much!

I'm so used to work with BTT so felt really frustrated one day without it.

Update—I've noticed that several hours later, on both my iMac and my MacBook Air, BTT was again disabled. Simply using the menubar button to re-enable it was easy, but perhaps something further is going awry?

Most likely somewhere in your BetterTouchTool triggers is one that has "Toggle BetterTouchTool Enable / Disabled" assigned that is triggered.

Fixed mine as well!

Imprint | Privacy Policy