Window snapping not triggering whilst webpage loading

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
I have three finger tap to Window Snap active window to the left half of the screen, and four finger tap to do the same but to the right half of the screen. When I click on a link in e.g. an email, whilst the page is loading the window snapping doesn't happen. I've used the HUD display to check that BTT is recognising the gesture, which it does. However, I have to wait until the page has finished loading until it then actually does the gesture.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro Trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 15" mid 2015
  • macOS version: Monterey 12.6.5
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 4.075

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

What kind of browser?
Unfortunately BTT can not influence whether an app responds to the "instructions" it sends. If your browser decides it is too busy doing other stuff, there is probably nothing you can do. However I have never seen such a behavior with any modern browser.

Safari 16.4.1.

It also happens with other apps, e.g. Excel, as well - I have to wait a few seconds or do the trackpad gesture several times before it registers and then performs the action.

It's weird because other gestures (e.g four finger swipe) work 100% of the team whilst the page is loading. It's just three and four finger taps that there seems to be a delayed recognition.

Upon further testing, I've discovered that the same issue - window snapping not triggering whilst pages are loading - also occurs when I switch the gesture from three/four finger tap to three/four finger swipe down. So it seems like a specific issue related to Window Snapping.

Any suggestions or possible solutions?