Window snapping bug present when using a trigger to change spaces by clicking on the menubar

Currently using Alpha 4.179 (2397). Issue was present on stable version 4.157. Issue presented only when updating from a previous version to 4.157. I do not know what previous version I was on (if you know how to determine this, let me know). I needed to manually download 4.157 to upgrade: the auto-updater would not perform that update, presumably because I was on a very old version <4.0.

Describe the bug
I have a few simple triggers that I've been using for years without issue. When pressing certain mouse buttons while the mouse is above the menubar, the computer "moves left a space" or "moves right a space."

After updating, very frequently performing this action results in the window snapping feature unexpectedly being activated. For example, I place the mouse in the top center of the screen over the menubar and press mouse button 4. The space is moved to the right. There's a window/application open in that space, and as expected, that window becomes active (upper left of the screen shows the name of the application). However, the window snapping preview overlay to maximize a window appears (a box encompassing the whole screen, in my case). Although at this moment I am no longer pressing any buttons, the overlay stays visible until further action. When I click something, the overlay disappears. If I left click on the menu bar, the overlay will disappear and the window will maximize. If I click elsewhere, the overlay will disappear and the window will not maximize.

Alternatively to this scenario, if I instead press mouse button 4 near the upper left or upper right corner of the screen, the same behavior may happen but with corner snapping instead of window maximization.

This bug sometimes doesn't happen and sometimes does. I can't figure out what conditions force it. Usually it happens several times in a row, or does not happen several times in a row.

This bug is only present with my trigger for changing spacing by clicking on the menubar. It does not appear to happen when I change spaces in other ways, like with a keyboard.

I have adjusted probably every window snapping setting available, and none seem to impact the bug (except turning off window snapping of course).

Affected input device:
Regular Mouse


Device information:

  • Type of Mac: 14-inch macbook pro
  • macOS version: 13.4.1
  • BetterTouchTool version: Alpha 4.179 (2397)

Weird, I'll try to reproduce this.

Does your BTT have the screen recording permissions in System Settings => Security & privacy? (These help BTT determine whether a window has been dragged or not, to see whether it should activate window snapping)

Thanks for the quick reply. I did not have screen recording permissions on. I just tried turning it on, but the problem persists. (I think the permissions were off before I updated as well but that's hard to verify).

[Interestingly though, turning on screen recording DID fix an unrelated issue that the "restore old window size" feature was not working. After turning on screen recording, it started working. Even more interesting, after turning off screen recording, it kept working!]

I tried to create a workaround where I required my mouse to be on the left or right of the screen to move spaces instead. To my surprise, the same issue occurred! Except instead of a corner snapping, now it tries to snap windows to the left or right halves of the screen. It seems the issue has to do with changing spaces while the mouse is being clicked and also at the edge of the screen.

Maybe in the meantime someone has a suggestion for using extra mouse buttons to move spaces left or right. I'd just allow the action without any stipulation on where the mouse is, but I also use mouse buttons 4 and 5 to navigate forward and back in a web browser...

Sorry I didn't get to look at this yet. Will investigate soon.