Wifi/VPN causing BTT to not resume

When at home this issue does not present it itself - but at work offshore with flakey wifi and some vpn usage, frequently find BTT does not resume after my Macbook is closed then reopened. Even after screensaver activates, sometimes.

It seems related to wifi and vpn :- if macbook is restarted/resmued and BTT is not working, then if i command-space to relaunch BTT and BTT does NOT work/launch, then once wifi is toggled off, then BTT screen appears and BTT works again. It's been a long term irritation which probably isn't apparent with normal good wifi.

MacBook Air M1 OS 14.4.1 (been issue from many previous versions)
BTT Version 4.504

BTT is the best - if more/all Macbook users had it, they'd still have that touchbar in production :wink:

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

Are you using VPN for the purpose of doing your offshore work?

If not, VPN's are retarded & a waste of time... unless you're routing DNS queries with something like NextDNS...

Anyways as to your issue, without going into other possibilities like firewall potentially blocking BTT go ahead and try:

  • Open up BTT, Open up Preferences (⌘+,)
  • Under Advanced Settings, click General
  • select the box that says "Restart BTT after wake from sleep"

(This is a bit unrelated but in that same section do you see the "Process Priority Helper Tool (Optional)"?
Are you using the Helper tool? It should tell you at the bottom if helper tool is active.)

Go ahead and try these real quick and lemme know what happened.


Edit: May 8, 2024 14:49
I just noticed you mentioned the touch bar at the bottom, although your issue doesn't seem to be directly related to it. On touch bar Macs, I recall there's a specific touch bar section in BTT's settings. You can set it to start up after a custom time interval, like 30 seconds.

As Andreas suggested, it might be a shell script attempting a network request, or possibly a combination of the VPN taking a moment to start up when you log in, causing BTT's request to fail.

Or do you maybe have some blocking shell/apple/java script in BTT that does a network request and fails due to the VPN?