Why does tapping clock take me back to default touch bar?

touch-bar

#1

Not sure if its a feature or a bug, but probably the latter.
My current settings are a mix-match of primarily a minimalist preset, with a few bits of Golden Chaos throw into the mix.

Now my main source of confusion is that at the moment whenever I tap either of the two Date/Time widgets, I get sent back out to default touch bar. If I press any modifier keys (Command, Option, control, or even fn) I get sent back to my BTT touch bar. Now, I've looked in all of my settings and I cant see anything that should be causing this behaviour, which leads me to believe that its a bug.
Here's a video showing exactly what I mean:

ALT:
Imgur will go here once Google photos finishes "processing"

Now here is the odd thing, I actually really like it so more than anything else I really want to know if there is a way to reproduce this in a way that doesn't return to BTT immediately when pressing a mod key, but instead waits for me to hit the BTT button in the control section (I'm thinking something alo g the lines that sets the clock tap to a "hide BTT" command. I get the feeling/maybe saw somewhere that there is a way to do this with a dedicated button, though I also haven't yet figured out how to do that either.

Cheers in advance,

Seth


#2

Hi Seth,

I think the "modifier" activating the BTT bar again, was a bug. It should already be fixed in the latest alphas. So now it should work as expected.

Your bar hides because you have assigned the "Toggle BetterTouchTool Touch Bar" action to the date time widget.


#3

Ah rightio, that makes sense thanks.

I'm not sure what the new cause is, but after fiddling with a few things I'm now having issues where pressing a modifier key while displaying the BTT touchbar will cause it to become hidden and instead show the default touchbar. I'm new to BTT, so I'm not sure which settings to look in for something that would be causing this.

If this isn't a setting but is instead a bug, I updated to the alpha update stream <10min ago, so idk what else to try


#4

Did you maybe configure BTT to disable when pressing a modifier key?


#5

If you export your preset (including settings), I can check what's wrong.


#6

I've somehow ended up with half of my stuff in an edited Minimalist preset and half in the default so here is both
Minimalist v2.3.bttpreset (97.2 KB)
Default.bttpreset (1.5 MB)


#7

Oh you seem to accidentally have set this option:

Disabling that should fix your issue.
Although this should cause the BTT bar to be completely hidden. I'll look into that.


#8

Okay so thats fixed the problem of mod keys hiding the BTT touch bar, but now I'm back to square one where tapping clock takes me to the default touch bar, but tapping a mod key causes the BTT touch bar to reshow. This is still an issue on the most recently available alpha update


#9

Ahhh I think I was finally able to reproduce this. (It only happened with a specific combination of things).

I think it should now work correctly in v2.709.


#10

Perfect, it's working exactly as expected, cheers for all the help.

Mind if I ask exactly what was so special about my setup/conditions that was causing it?