What am I doing wrong? This button isn't working. I feel like it's something obvious.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

A button I made does nothing when I click it. It works when I do the same thing via the menu but not the button I made to use the menu.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: mbp m1
  • macOS version: ventura
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I just did tccutil reset All com.hegenberg.BetterSnapTool
to get rid of the popup. Could it be related to that? It made me re-do accessibility but still, nothing.
It seems like most of the buttons are working except the ones related to the many access. Am I doing it wrong?

Have you tried using the position instead of the menu name?

Or why don't you use the app's shortcut for the button?

Sometimes there isn't a shortcut. I could make one I suppose. But this seems (or seemed) the most foolproof way of doing it. I'll try the shortcut but it bothers me that it's not doing the menus. I mean, if it doesn't work there must be a reason right?

Some special apps do not hold their menus available all the time. It's possible Final Cut generates them on the fly, then BTT might not be able to trigger them.

In that case I recommend to use System Preferences => Keyboard => Keyboard Shortcuts => App Shortcuts and create a specific shortcut for it there (this can then be triggered via BTT as well)

I use several of these menu items shortcuts. None of them work if the last item is the name (instead of a number/position). All of them look like this.


I don't know why that's necessary, but this way all of them work.

if they are dynamically generated, the app might not know the name of the item itself yet. Thus the idea using the number instead is good!