Wavebox 10 (Chromium app) does not trigger Snap Areas, respond to screen-edge window snapping, or allow double-click on titlebar

Describe the bug
I use an email/web app client called Wavebox. It just updated to a new version, version 10. Since that upgrade, I cannot use Snap Areas with the Wavebox window, and have found that its window does not respond to being dragged to a screen edge, nor can I double-click on its titlebar to maximise it.

Regarding Snap Areas, I have tried the following:

  • Select the Wavebox 10 window
  • BTT -> Snap Areas -> Create New Snap Area Using Current Window as Template
  • Save the snap area
  • Now try dragging the Wavebox 10 window. The Snap Area does not appear. This is the same regardless of whether I filter the Snap Area to Wavebox.app specifically, or leave it unfiltered for all apps. The Snap Area just doesn't appear while I'm dragging the Wavebox window, as if BTT doesn't even detect I'm dragging a window.

Wavebox 10 is a Chromium-based browser-style app. Previous versions of Wavebox were using a framework called Electron, not Chromium. I therefore think it's the change to Chromium that has caused these issues.

I performed the same tests with the latest version of Google Chrome, and found that Chrome does respond to Snap Areas, and to screen-edge snapping. But it does not respond to double-clicking its window to maximise.

I remember some bugs related to Chrome in BTT from a few years ago, and therefore wonder if there are general issues with Chrome/Chromium in BTT, and that specific fixes have been added for Chrome, but these don't work for other Chromium apps eg Wavebox 10?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Mouse/Trackpad

Screenshots

Device information:

  • Type of Mac: Hackintosh emulating iMacPro 1.1. Intel Xeon X5670 CPU, 48GB RAM, AMD RX Vega 64 8GB GPU.
  • macOS version: 10.14.6
  • BetterTouchTool version: 3.220 (1397) alpha

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Let me know if debug logs would be of help.

Here's a link to download a free trial of Wavebox 10 for testing: https://wavebox.io/

Imprint | Privacy Policy