Volume/ Brightness widgets invisible latest alpha

v3.362 since installing this update the BTT provided brightness and volume widgets no longer show on my touchbar. I can press where they should be and they do work but are totally gone visually.

Touching where they were brings up a grey square with a black icon inside but only while touching

Restarting etc does nothing to bring them back.

Did you also try to restart your machine or just BTT? I don't think there has been a change to the sliders, they seem to show up fine here.

It's not the sliders, it's the default icons for the end buttons on each slider. If I go in and manually add an icon for left and right then they show but the nice looking default icons seem to have disappeared?

The way I use the widgets is they are made small enough that the slider doesn't show just the up/down buttons.

Just to update I restarted my machine with no changes. This only happened when I made this update about an hour ago. If you look in my BTT config you can see there are now no icons showing there for the widgets?
Screenshot 2020-04-19 at 17.53.37

This is how it looked before (for clarity)

Weird, what is the widget width set to? (I think in your case it would be better to use buttons instead of slider widgets, you don't seem to be using the slider?)

Are the show left / right icon options still checked?

Maybe try to press the reset button on the right side of the icons.

I have attached an image showing everything. It's as though BTT has lost the path to the icons? where were they stored/ can I just re add them manually? Reset button and restart tried but no effect.

Looks all good, the default icons won't show up, that's normal. Weird. Which macOS version are you on?

Does the icon selector let you choose different icons?

I was 10.15.4 but reverted due to crappy scrolling changes so 10.15.3
All worked perfectly for me right until BTT restarted to install the update.

Yes icon selector works perfectly and they show

Then maybe for now search the icon selector for brightness (the ones in the batch section) and volume (the ones in the ionicons section) are the default icons.

I'll check whether I can reproduce this on my other machine.

I had a look but I couldn't find any icon that matched the default ones (They looked like the oem apple icons) but I will go through them all again and see.

Ah wait you are right the default ones are not in there.

That was my reason for using the widget over buttons. The icons look much better (Also fed into my request to extract all oem icons and provide them for use in the icons section but thats another topic)

Someone did that: [v3 Update] Native Apple Touch Bar Icon Pack for BTT
I can't include them in BTT for legal reasons.

The issue is very weird though. It seems like the system doesn't find the standard icons? How did you go about downgrading to 10.15.3? Do the icons still show correctly in the system Touch Bar?

You can also downgrade to any previous BTT version via https://folivora.ai/releases but I'm not sure whether it's really the alpha that causes the issue

Ah I missed that.
I used a time machine backup to restore but that was a week ago at least. All apple touchbar stuff is perfect and icons show fine. How/ where are the icons used for the widgets retrieved from?

If no custom icon has been assigned, they are referenced by their name and then the system frameworks handle showing them (e.g. NSTouchBarAudioOutputVolumeLowTemplate ),

So the icons are still there, apple can access them but BTT now can't. Was anything related to that changed in the Alpha?

I don't think so (and they are showing fine here), that's why I'm confused :slight_smile:
Maybe go to Help => Export Diagnostic Debug Information and send that to andreas@folivora.ai, this would allow me to reproduce your exact setup.

I will send that right away. Yes it is quite strange and you would expect it to happen on all systems if a path or similar was broken with the update, but software is software....

Unfortunately even with your exact setup it seems to show fine ;-(

I'm a bit out of ideas right now, let me do some tests.

Thanks, I will remove and reinstall an older version and use a backup I have from before I upgraded macos and report back