Very novice - keyboard shortcut help. Date and Time key.

Hi there

I just downloaded this app with the intention to be able to add the current time and current date with a keyboard shortcut.

After trying with automator and Terminal a person on Reddit (ulysseric, a really detailed response.) suggested this application would make it much easier and there was a setting pre installed.

Could anybody provide any assistance in making this a possibility?

Thank you very much

You can assign the "paste/type custom text" action:

1 Like

I think easier is a relative term. You didn’t provide a link to the Reddit post, but my impression from what you said is that ulysseric doesn’t know how to use Automator.

Although you’ve been shown how to use BTT to insert the date and time, if, as you said, that was the only reason you downloaded it, then it seems a shame not to show you how to solve your problem using Automator to create a systemwide Service (or Quick Action in Mojave):

Shell script code
date +'%Y-%m-%d %H:%M:%S'

You can assign a keyboard shortcut to it via System Preferences > Keyboard > Shortcuts > Services, where you’ll find the name of your service under the Text category.

1 Like

Thank you very much, I tried this and again it worked in automator but didn't show in system preferences. I think I might have jammed dup this part of the computer from trying too many different ways.

I have better touch tool as part of an already existing subscription, have looked at it before and have planned to sit don and go through it at some point. This will probably be that moment. My knowledge with computers is poor so I am learning on the go.

Thank you for your help and assistance.

Thank you, I implemented this and can now use they desires keyboard short cut.

Hi there,

I have been using the short cut for sometime and it's worked well but now when I use it it pastes the buddhist calendar year

08/28/62 12:05:02 PM

I've gone through all the settings I can find in my computer to do with the date and all of them are set to the Gregorian calendar.

Do you know what might be causing this change and how to set it back to show the year as 2019? I have traveled to Thailand before and wonder if that is somehow linked to this change but no idea how to go about it.

Thank you again.

Maybe you accidentally changed the region settings in BTT?

The region setting bit was blank but after setting to English and restarting it's switched back and is now working as desired.

My previous blind fiddling must have done something but thank you for the timely and effective response!

1 Like