Ventura: "Mic Key" not Working

Describe the bug

Before updating to Ventura, I had "Mic Key" mapped to F16 on my external keyboard. Now it no longer seems to work. BTT Live View detects the key correctly. Verified key works correctly on my MBPs keyboard. I tried remapping it again, and but same result.

I also verified that it was correctly set in MacOS System Settings

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

External Keyboard

Device information:

  • Type of Mac: MBP 16" M1 Max 32GB 2021
  • macOS version: 13.0.1 (22A400)
  • BetterTouchTool version: 3.939


I quickly tried here, but sending the Mic key still seems to work ok.

Is it maybe the F16 key that causes issues? Does it work with other BTT functionality? I don't have a keyboard with F16 here right now, thus can't verify the exact setup

I just noticed you have the "auto-adapt" option active. Could you try disabling this? It shouldn't matter for this key and can cause issues because the system might not be able to map that key correctly.

That did it! Thanks Andreas. I just realized that Auto-Adapt is meant for people using multiple language layouts on the same keyboard - correct? As I only ever work with english+english keyboard, I suppose it's good practice to always leave this off?

Also, just in case you're interested in what causes this, this may help: Before getting your solution, I had tried changing the key in MacOS system settings to F16 (as a temporary fix), and that made BTT crash whenever I pressed. Here is the crash report BTT Crash / F16 -

Correct, you can always leave auto-adapt disabled.

The crash after changing Mic to f16 is happening because now pressing F16 will cause an endless loop (triggering f16, which triggers f16, which triggers f16...)

1 Like