Ventura Issues - Inputs Stuck + Cursor Freezing + All BTT Functionality Ceases

Describe the bug

Cursor Freezing: I haven't been able to reproduce reliably, but it is definitely tied to whatever is happening with the keyboard because if I start pressing keys on the keyboard ramdonly (when I notice that the bug is active) then the cursor will really hang/lag as I move it around. It does not however happen ONLY when inputs get "stuck", as I'll describe below...

Inputs Stuck: I'm able to reproduce it reliably. It happens only inside BTT, after trying to edit an action and hitting "save".

If, for instance, I am editing a "Delay" action, after I input the new number and hit save, the keyboard immediately gets "Stuck" on... something. What happens is that if I try to re-edit that same action, I can no longer type because as soon as I click the textbox, the textbox loses focus.
If the action I am editing is a dropdown menu, then clicking the dropdown immediately closes the dropdown again.

All BTT Functionatily Ceases: ... and after this bug is "active", all BTT actions cease to work. BTT will remain open, but any and all functionality that has been configured is stopped - Including the "Reverse Scroll".

Bonus:...also, after activating the bug, I have experienced other weird behavior outside of BTT... but it's so out weird and inconsistent that I am not sure it is even worth describing. I'll do so anyway, just in case: basically I have seen the keyboard get stuck across apps outside of BTT and impossibilitate further input, with every key that I press making the screen do a "slow" white flash. I have a video of this if you want it.

Conclusion: Essentially I can no longer edit BTT actions and will have to stick with my current preset for the time being, in addition to some other weird behavior.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MBP 16 2021 M1 Max
  • macOS version: 13.0
  • BetterTouchTool version: 3.936

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

This does not sound like a bug in BTT but maybe something is weirdly activating and deactivating the BTT window and stealing the focus?

I'd first try to quit BTT and run it in safe mode - maybe it's some automation you have configured inside of BTT doesn't work as intended. Safe mode prevents any BTT trigger from triggering.

To enter safe mode, use this terminal command while BTT is quit:

defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled NO

(change NO to YES to disable safe mode again).

Hm. I mean, the reason why it seems to me like it is a problem in BTT is because the action that causes this to happen is specific to BTT (saving an action). Otherwise BTT works fine up until that point.

I did try what you suggested and the behavior is the same. By the way, pretty sure you have YES and NO inverted in your post - but regardless, I tried it both ways.

I also tried to create a new preset and select it as a master, with all other presets being Deactivated + Hidden. So on a brand new preset, if I try to create a new action (e.g. "Delay next action"), set a value, and then save = BUG, as described previously.

Unless this is related to actual BTT settings, and not actions? What do you think?

That said, I must note that nothing in my system has essencially changed between Monterrey and the upgrade Ventura, not even inside BTT.

The weird thing is, if this is a general issue in BTT it should pop up on other systems as well, basically rendering BTT useless - but I haven't had any similar report yet :sweat_smile:

Would be great if you could go to Help => Export Diagnostic Debug Info and send the result to

I hear you! Maybe I'm special :smiling_face_with_tear:.

Done. Sent the debug along with 2 videos! Thank you.

Thanks a lot for the detailed logs, that helped a lot. Using the logs I indeed found a stupid edge case in the 3.936 alpha that could lead to this behavior.

Would be great if you could verify that it's fixed with 3.939 alpha.

1 Like

Oh man I fucking love you. The best dev for the best app! Looks to be fixed!

As a side side note, after 5 years of BTT I have probably close to 1000 actions if not more. My machine would be unrecognizable without it. BTT gives me superpowers. Thanks again Andreas.