Variable User Path with Tilde/~ in "Start App/Script etc"

Hi there!

I saw your last Alpha-Update regarding the manual path input when using the action "start app/open file/Apple Script". I tried replacing the userpath with a variable path (e.g. instead of "file:///Users/XXX/Library/file.scpt" i would like to use "file://~/Libray/file.scpt") but that doesn't work. Could you add such functionality? Having the ability to enter paths with a ~ would make importing presets on a different device so much easier, when the user path is not the same but the rest of the path is.

Thanks in advance and best regards!

i think it should work if you remove the file:// in front

Thanks for the reply!

Unfortunately it didn't work without file://
I tried every combination with and without file:// in the beginning, but only "file:///Users/XXX/" would work. Every other combination, the little script icon above the path goes blank immediately.

Ah it's expected that the icon goes blank, I haven't implemented the variable path resolution for the icon files yet. But launching it should work (just tried with a few apps)

I stoped trying it after I saw the blank icon, but it didn't work at first anyway. My problem on top was that the path to the script file contained spaces (InDesign folder paths, can't change them), which BTT translated to "%20". So it looked like this: "~/Library/Preferences/Adobe%20InDesign/Version%2015.0/de_DE/Scripts/Scripts%20Panel/ContentToFrameDialog.scpt"

I had to replace the "%20" again with actual space and then it worked! I don't know if BTT needs the %20 if its not a variable path, but I think it would be better to remove them in the "saved path" display.

Thanks again for your fast help! :slight_smile: