🆕 [v3.6.9] AquaTouch – The Powerful Touch Bar Redesign.

Ah the sharing container didn't restart after an update :wink: should be working again.

1 Like

Since the 3.5.0 update, none of my notification badges are working. I reset the variables using the debug mode and made sure DND is off. So far the affected apps are WhatsApp and Outlook (both are enabled in the BTT configuration window).

I'm away from home at he moment but do note that you'll need at least BTT v3.04 for the new AQT as the Notification Badge code is now based on a new BTT function, so try updating if you haven't already.

I also see another case of the random CS/BTT behaviour reset in your finder bar screenshot @Andreas_Hegenberg

@yuuiko @Andreas_Hegenberg I am using BTT 3.063 at the moment

1 Like

Hei man!

Mail notification badge now works perfectly (I feel so dumb :sweat_smile::joy: ..)

Your questions:

  1. Quick Apps group for me it's ok now, because I've never used app switcher

  2. Yeah SoundCloud auto opens perfectly

  3. What do you mean with "Change to the fn key as the AQT modifier"?

  4. Airpods widget works great for me!

  5. Nah, modifier action suggestions are not so annoying! I don't use it, but they're not so intrusive to want to remove them

  6. Uhmm, maybe could you add terminal app? But I sincerely wouldn't add other apps at the moment because the main apps are already there

My new question:

  1. It sometimes happens this strange bug (not only in After Effects)

Hope this reply will help you @yuuiko!

Great, thanks!

How would a terminal app work? Could you make a mockup set?

The gesture bar sometimes resides after sliding @Andreas_Hegenberg

Still checking. It's working fine for me...

I got this when I opened my laptop today

Quite a few issues there I think.

@onaforeignshore @Dom

Could you see what the notification badges are returning in BTT Configuration? Are there any error messages?

@yuuiko The script for Outlook/WhatsApp notifications returns ""

A quick debug in the script shows that LCL_DNDStatus returns "missing value".

Try re-enable the DND handler. Is this one returning any errors?

It may be because the DND status variable is not set. The handler should set this up.

DND Handler returns "". When I added return get_number_variable "SystemDoNotDisturbState" at the top of the script, it returned missing value

This seems to be a BTT issue... The new notification badges use a new BTT variable. Are you sure you have the right BTT version?

BTT 3.069 (1176)

Scripting BTT (in configuration) shows:

Persistent Variables
No Persistent Variables Set

Temporary Variables
BTTActiveAppBundleIdentifier: com.hegenberg.BetterTouchTool
BTTCurrentlyPlaying: 0

This variable is only loaded on demand, thus it's not shown in the general variable overview yet. Will add some note about that.

However it should not return missing value (at least on macOS Mojave).

tell application "BetterTouchTool"
	get_number_variable "SystemDoNotDisturbState"
end tell

I'm on Mojave 10.14.5

tell application "BetterTouchTool"
    return get_number_variable "SystemDoNotDisturbState"
end tell

returns missing value

Maybe try to restart your system, might be some weird Apple Script issue. Even if BTT can't get the state it should just return 0

@Andreas_Hegenberg I restarted and still get the same result

strange, then I currently don't know what could cause this. I can't see anything that would lead to a missing value here :frowning:

You are sure the latest BTT is running and no other BetterTouchTool version is started?

1 Like

Total noob here but is there a way to change the Fn key + left/right arrows to something else? I use that to jump to the top or bottom of a page (home/end) and it gives me a heads up display for FF/Rewind. Other than that, this is awesome.

EDT: Nevermind, I found it.

1 Like