[v3.6.8] AquaTouch – The Powerful Touch Bar Redesign.

That's interesting...

@Dom Could you please give me some pictures of the touchbar and the currently open application?

note: press ⌘⇧6 to screenshot the touchbar.

@yuuiko of course!

When I'm on desktop

When I'm on safari

And randomly appears this earth icon on the left side

@Dom Ah, this is a problem with the way i handle the global setting.

First, Exit the better touch tool bar (tap to see the white icon)

While closed, Hold the better touch tool icon untill the highlight disappears. Nothing should happen apart from the highlight disappearing.

Then, tap the better touch tool icon again.

@yuuiko should this advice fixes icon/buttons missing? Because nothing seems happening and I've still the same problem :man_shrugging:

P.S. I'm sorry for this "stupid" problem ... Maybe can I help you sharing my config or other details!

Holding the BTT button activates a 'global mode'. It's just BTT behaviour.

What you're seeing is an error message that I put in this global mode since the mode locks up my preset.

You must've accidently held the BTT button down somewhere, that's all.

I guess it's hard to explain how to get out of the mode. Please wait for an edit which will include a video about how to exit this mode.

1 Like

Try this:

Sorry for my answer delay but I wasn't able to upload video on this forum ....


P.S. Still doesn't work :\

1 Like

Just try using a normal link, as i'm using some special method

edit: yep I see it

That's interesting, the preset is not designed like this...

Looking into a cause
In the meantime, if you have any more information then please share!

Maybe looking into my settings will help you in some way ..

edit. Ops, I missed it! After that I pressed buttons like you in the video and after restarting BTT, earth icon disappeared!


I see a potential issue:

Screen Shot 2018-09-17 at 9.29.28 pm.png2254x2280 1.06 MB

Are these 'Applications' missing from the list?
If they are present, What do they contain?

Damn I don't have any of them! Should I install these app before install preset?

These are not apps rather they are conditional activation groups. They activate when their various rules are true. You do not need to install any apps as these are not 'apps'.

Could you rename your copy of the preset (e.g. Dom_AquaTouch_v2.0.0) and send it over so I can check it up?

I've just checked this by downloading the preset from my link and importing it myself, just like any normal person would. I've found an issue which seems to be a BTT glitch, where all the conditional activation groups get merged into one.

@Andreas_Hegenberg, this is quite an issue since this preset relies on them heavily.
It seems like this is an import issue as the web summary keeps them seperate as usual.
Could you please look into this?


@Dom, I would still like to see your copy of my preset to verify this finding, if you're alright with that.

Edit: Try opening Illustrator or any other supported app (apps that have icons in the side column). The preset should still work with these?

Nothing happened.

Edit: In version 1.0 beta Photoshop was working but Illustrator and After Effects not (maybe because I've newer version of them) and in version 2 no apps works ..

Yes, this isn't a fix rather it's to help me see what happened on your side.

I'd like to check what happened within your copy of the preset so:

  1. click Manage Presets,
  2. select the preset then:
  3. click 'Export Highlighted', save the file and send it over so I can take a look at what's wrong (link here, etc).

@yuuiko here you are https://drive.google.com/open?id=1PviUc9DVUIUqW3VRdJ5HOn5mdq9CJWXw

1 Like


Thanks for that, I've taken a look and it seems like it's the same issue.

This is most likley an issue with BetterTouchTool and I'd need to discuss with @Andreas_Hegenberg to confirm/fix it up

Issue Posted on bug reports:

Thanks for your co-operation, @Dom!
Let's hope it'll be fixed soon. In the meantime, is there anything else you wanted to mention?

Edit: I've just seen your edit:

Edit: In version 1.0 beta Photoshop was working but Illustrator and After Effects not (maybe because I've newer version of them) and in version 2 no apps works ..

And i'm curious to find out why. I'm guessing that, yes, the versions are not matching therefore BTT isnt sensing the right app
Could you try:

  1. Adding your own Illustrator using the + button in the apps list
  2. Add a 'test' button
  3. Try if this works with Illustrator
1 Like

I'll look into that later today!

1 Like

@yuuiko yeah adding Illustrator (or Animate in my case) to the list it works properly, so I think it's version related.

P.S. These are the versions I've on my pc

I think it's version related also because if I add for ex. Illustrator to the list, BTT add it again, although there is your version too.

1 Like

Swamped with work today but I'll check out v2 tonight! :smiley:

1 Like
Imprint | Privacy Policy