Using Launch > Desktop gets me a large folder icon


I have two keys configured in BTT, one opens my Downloads folder, one opens the Desktop.

I've followed the same steps for both of them and they both work. But the one which opens Desktop also displays a large "preview icon" of a folder. I've tried removing and recreating the action in BTT but it always seems to do the same thing.


There is nothing in that action that could trigger such a preview, your configuration in the screenshot looks good.

Could you post a screenshot that shows the shortcut definition?

For testing purposes I've used the "Click here to record a shortcut" button in the Keyboard Shortcuts section of triggers, to take a look at what all the different keys on my keypad are detected as by BTT.

The keypad-key I'm trying to use to trigger "Open Desktop" is detected as "Space". I wonder if this is somehow related to what I'm getting when I open Desktop with TT? Outside of BTT, with the Desktop folder highlighted in the Finder sidebar the Mac will attempt to show a Preview of the selected item when I press the space bar, as it does with any file and for Desktop it would show the large folder icon that I get from within BTT.

I've tried assigning a different keypad key to my "Launch/Open -> Desktop" action and it works perfectly, it's just this one keypad key, the one which BTT sees as "space". Unfortunately I'd really like to use the particular key I'm trying, as it's bigger than the others on the keypad!

  • When I use a Keyboard Shortcut trigger to launch -> open Desktop it works ok, I don't get the large folder icon of Desktop BUT the space bar is no longer functional on my main keyboard.

  • When I use a Generic Devices trigger to launch -> open Desktop I get the large folder icon of Desktop BUT the space bar works fine on my main keyboard.

I've tried selecting/unselecting "Works on keyboard with same type as used for recording" in both cases but the results are the same. Video and screenshots attached.

you need to select the „works on keyboard used for recording“ option on the shortcut, otherwise it will block space on all your keyboards.

Space activates quicklook, which explains what you are seeing!


I don't know whether the mini-keypad and my Microsoft Scuplt keyboard somehow identify as the same device type, but I'd already tried the "works on keyboard used for recording" and the same issue continued to happen. I lost "space" on the Microsoft keyboard.

However I now have a solution. Combining Karibaner Elements with BTT. (

In Karibaner I modify the incoming "space" from the keypad to be an obscure key that I'll never use, in this case F20. My keyboard doesn't even have an F20! When I press the problematic keypad key to record a shortcut in BTT it now sees "F20" (displayed as a Chinese looking character) instead of "space".

Now when I use the keypad key I can open Desktop without also sending the preview shortcut ("space").


Weird, which version of BTT are you on? (they should have different identifiers)

Version: 4.333