Upgrading An App Causes BTT To Disconnect Associated Triggers

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
I updated my web development tool, Pinegrow this evening and lost the ability to have BTT display my custom app-specific touch bar triggers. Turns out BTT changed the app icon to a question mark. The updated app had the same name as it always has. I ended up having to drag the Pinegrow app into BTT and copy and past all the triggers to the new app icon. When I had to downgrade to the prior version of Pinegrow because of a bug I discovered, I had to do this procedure again.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2019 MacBook Pro 16"
  • macOS version: 13.5.1
  • BetterTouchTool version: 4.375

Additional information (e.g. crash logs, related issues, etc.):

unfortunately this can happen if an app changes its bundle identifier (apps should not do this, but maybe they had some special reason)

It‘s basically the identifier that identified an app with the system as name name might change or be different on various languages

You can add the app again and copy & paste the old triggers