Updates fail every time.

I should have reported earlier, but for months and months, when I get notified of an update (I'm on Alpha), I either get an Update Error! (an error occurred in retrieving update information) if I manually check, or I get a message saying there's a new version, click the button to install, but this fails.
I'm on a Macbook running Ventura 13.4.1.

most likely something on your system is blocking access to the update server. Maybe firewall or hosts configuration?

Thanks. I'm running Little Snitch but have no connections blocked for Better TouchTool app. Might it be associated with a different process name?

Any other suggestions? Is there any more diagnostics I can check associated with this error?
Screenshot 2023-09-01 at 7.25.33 AM

have you tried updating manually once?
(via folivora.ai - Great Tools for your Mac!)

Maybe there is some permission error or something else is corrupted with your current installation

Yes, I removed and downloaded a fresh version. That seems to have solved it. Thanks.