unable to launch the latest version on Catalina

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
App crashes on launch.

Device information:

  • Type of Mac: mbp mid-2010
  • macOS version: 10.15.7
  • BetterTouchTool version: 3.704-1842

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Process: BetterTouchTool [1036]
Path: /Applications/BetterTouchTool.app/Contents/MacOS/BetterTouchTool
Identifier: BetterTouchTool
Version: ???
Code Type: X86-64 (Native)
Parent Process: fish [1025]
Responsible: Terminal [1022]
User ID: 501

Date/Time: 2022-01-06 12:20:30.730 +0300
OS Version: Mac OS X 10.15.7 (19H1217)
Report Version: 12
Anonymous UUID: 28B3E8BC-2647-499B-09CB-1FD9A06F1AAA

Time Awake Since Boot: 770 seconds

System Integrity Protection: disabled

Crashed Thread: Unknown

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffeea8dbb30
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x00000001151af000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary images description not available

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 444
thread_create: 0
thread_set_state: 0

Model: MacBookPro6,2, BootROM, 2 processors, Dual-Core Intel Core i5, 2,4 GHz, 8 GB, SMC 1.58f17
Graphics: kHW_IntelGMAHDItem, Intel HD Graphics, spdisplays_builtin
Graphics: kHW_NVidiaGeForceGT216Item, NVIDIA GeForce GT 330M, spdisplays_pcie_device, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x014F, 0x54533531324D534B363456314E2020202020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x014F, 0x54533531324D534B363456314E2020202020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
Bluetooth: Version 7.0.6f8, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Samsung SSD 860 PRO 256GB, 256,06 GB
Serial ATA Device: ST9320325ASG, 320,07 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: IR Receiver
USB Device: Built-in iSight
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Internal Memory Card Reader
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM2070 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus:

sorry, no idea what was wrong, after reboot it started launching.

the thread can be closed.