UI changing window/view everytime action added

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
Whenever I'm trying to create a new group or named trigger, or add an action to the current trigger, the UI switches/activates the 'Global Settings' pane and loses focus on the current element (short video example below).

It's been this way for months and I can't figure out why it's happening and can find NOTHING online about somebody else having the same issues.

Maybe some shortcut getting sent in the background...? I've got NO idea...

!!! UPDATE: This is apparently limited to when the right-most/settings panel is "docked". If I allow it to be free-floating, it behaves as expected. This will work temporarily, but I'd rather not have two windows to deal with all the time, but this is certainly much better. Very curious....
(*See second video of behavior difference with docked vs undocked panel.)

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2020 Intel i7 2.3
  • macOS version: 12.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one"): 4.065

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Struggling with the exact same thing for months now. It is especially annoying when you add a new trigger or action within a group, because the UI takes you out of the group back to the main screen.

Maybe we have missed something in settings @Andreas_Hegenberg ?

Device Info:
MacBook Pro 2018 2,6 GHz 6-Core Intel Core i7
MacOS 13.2.1
BTT version 4.069

yes. very much so. even the "solution" of undocking the settings doesn't work, b/c it gets reset almost immediately.