Two lines Apple Script Widget - Font size not adapted for the second line?

Describe the bug
Could it be that the "Font size" is used only for the first line, and the second uses the default size?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Default text size it 12.

Device information:

  • Type of Mac: MacBookPro15,1
  • macOS version: 10.14.6 PB
  • BTT version: 3.065

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Download the widget here.

ah I have just added support for multi line date widgets in v2.066 (which is not online yet). Will upload in about half an hour.

1 Like

Funny. Thanks :wink:

This is happening for me for the two line calendar and also the two line forecast widgets. The second line does not seem to use the same font size. Worked fine in 2.xx, but just updated to 3.069

Solved it! Add a second line in the name of the widget, and the Font Size for the second line will appear inside the settings!

I have the same issue, but with an apple script widget which outputs two lines. Was fine in the previous versions, broken in 3.069. For apple script widget there is no second line size setting.

I'll add some compatibility code to retain the old behavior if no second line font-size is set soon.
@TouchAddict, if you give the widget a two line title, the font size setting will show up.

Thanks Andreas, that worked! For some reason though, it looks like the second line is using a different font: image

1 Like

Thanks! It drive me nuts yesterday evening wondering if it was me or if the two lines were different! Thought it was tiredness, but apparently we all lack some sleep :wink:

ah thanks for noticing, for some reason the font properties seem not to be applied to the second line. Will fix that :slight_smile:

Fixed in v3.070 (will be online in about 10 minutes)

The behavior is now like this:

  • if there are two lines and no explicit second line font size is set:
    • if two lines can fit with the selected line 1 font size: use the same size for the second line
    • if only one line can fit with the selected line 1 font size: automatically use a smaller one for the second line
  • if an explicit second line font size is set, use that - no matter whether it will fit or not.

Thanks Andreas, its working as expected now!

Hi Andreas, thanks for explaining the new behaviour. Having a similar issue here too using a Shell/Task widget here (via a JSON response), and getting different font sizes for the second line.

What's the JSON key for forcing the second line to a specific font size please? Have been using font_size so far.


make sure to update to v3.070 alpha - then it should work as before when not setting the font size explicitly.
Setting the font-size for the second line manually requires you to add a two line title to the shell script widget, then it will show the configuration.

1 Like

Ahh, sorry, I thought it had updated to the latest, but it wasn't installed yet.

Ignore me... looking good again now! Thanks a lot

1 Like