Two Line Widgets Broken in macOS Mojave

Describe the bug
A clear and concise description of what the bug is.

After updating to macOS Mojave, my two line widgets (return includes a newline character) do not work. Instead, the first line appears but the second line is blank. However, if I run the widget in the AppleScript window, the return shows both lines. Please fix this, I use newlines in a bunch of my widgets!

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 15" 2017
  • macOS version: 10.14.0
  • BetterTouchTool version: 2.641

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

They're still working for me in BTT 2.641 & macOS 10.14

Strange, I've tried restarting BTT and my computer... I'll try uninstalling and reinstalling to see if that fixes it.

Nope, still not working!

Weird. This also seems to work fine here.

I'll check if I can reproduce it somehow, maybe related to the chosen font size?

Yes, this was the issue! I had been using 13.3, which was the largest possible which still fit on two lines, but this appears to have changed to 12 with macOS Mojave. Thanks!

1 Like