Two instances of BTT in the Security & Privacy preferences. Cannot delete.

For some reason (I suspect because I have two licenses: one through setapp and another directly) I've ended up with two instances of BTT in my Screencapture privacy preferences on Catalina.

BTT standalone isn't installed anymore and right clicking and "show in finder does nothing. BTT standalone doesn't show in /var/db/locationd/clients.plist and nothing I do can make this disappear.

Do you have any ideas? I'm a bit OCD about this sort of thing and it drives me nuts every time I go in there.


Screenshot 2020-05-31 at 11.09.28 !
Screenshot 2020-05-31 at 11.09.38 !

try this terminal command:

tccutil reset All com.hegenberg.BetterTouchTool

Ah tried that before:
tccutil: No such bundle identifier "com.hegenberg.BetterTouchTool": The operation couldn’t be completed. (OSStatus error -10814.)

In that case only

tccutil reset ScreenCapture

will help, however this will remove all items from there and you'll need to grant the permissions again.

I just followed these steps, and v2.428 still does not request Screen Recording permission.

Is there a cmdline that I can run to make BTT request these permissions again? I think this is stopping BTT from window snapping my Chrome windows, as Chrome does have Screen Recording permission... Try joining a browser based video meeting (e.g. Google Meet or Hangouts) and sharing your entire screen. I was using Google Meet.

Ah yes, Thanks so much. This worked for me but how do I re-add BTT? It doesn't seem to ask permission again.