Triggering 'Show Notification Centre' breaks all other 'App-specific' keyboard shortcuts until you "reactivate" the active Application

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
Bit of an interesting bug. Been noticing that my keyboard shortcuts within a certain app will stop working. I've come to realize this happens right after I trigger a separate keyboard shortcut to "Show Notification Centre". When I close the notification centre and try to use other keyboard shortcuts mapped within BTT on the active app - it doesn't work anymore.

To provide more context, an example workflow:

  1. Working within PDF Expert. I have "CTRL + U" mapped within BTT (specifically to the PDF Expert application) to PDF Expert's underline text function, and triggering this works fine.
  2. I click a separate keyboard shortcut to "Show Notification Centre", and hit it again to close it, returning to the "PDF Expert" active window.
  3. If I try and activate my "CTRL + U" shortcut again, it won't work and the Mac will chime the "error" sound that plays when keys pressed don't corresponding to anything.

This is reproducible 100% of the time.

The only way I can get it to work again is to click on a separate App, and clicking back into PDF Expert (or restarting BTT will fix this as well). I suspect this has something to do with how the "Show Notification Centre" trigger works - it takes you out of your "Active App" and any keyboard shortcuts mapped to that specific App doesn't work anymore because BTT no longer recognizes that you're within that app.

Interestingly - the native "Swipe Left from Edge" way to launch the Notification Centre using either the Macbook trackpad or Magic Trackpad do not cause this issue.

Any thoughts?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2017 15" MBP
  • macOS version: Latest Catalina
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.4045

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Any thoughts here?

Imprint | Privacy Policy