Trigger Dissappeared from UI (Workaround Included)

Describe the bug
I had a duplicate Named Trigger that disappeared from the UI but was still active and conflicting with the remaining active trigger of the same name.

OK, long story time. Basically I had set up a few named triggers with multiple actions that I needed to reuse and in the keyboard section... so I copied them over (the entire named trigger, not just the actions). They pasted, and even retained their "Named Trigger" Type. I proceeded to modify them, but I noticed things were weird (e.g., when I was creating actions inside the trigger they didn't create properly, and moving things around too was buggy). To be honest I have experienced similar in BTT before under actually normal circumstances, so I didn't think much of it. But eventually I tried moving one of the triggers and it just dissapeared entirely from the UI. I tried using the search function but it just wasn't there... except it was. How do I know? Because when I activated the original named trigger, BTT popped up the little context menu and asked me which one I wanted to use since both had the same name.

But, yes, I did figure out how to get the trigger to display in the UI, at least partially. I called each trigger in the hopes that both would appear in the Recently Used section... and they did:

The missing trigger is the second one. I note it doesn't have the little blue bar for whatever reason (but I also made sure to compare UUIDs). But yeah, I deleted that sucker. Who you gonna call? :ghost:

Device information:

  • Type of Mac: Macbook Pro 2021 16" M1 Max
  • macOS version: 14.4.1 (23E224)
  • BetterTouchTool version: 4.587

Additional information (e.g. crash logs, related issues, etc.):

Seems to be the same thing that happened to this other guy:

Andreas, if you'd like to explore this further, I exported debug info and also exported my preset before removing the ghost trigger. Maybe it can help you figure out what happened and why it became invisible?

Many thanks!

the problem is, you can’t copy one trigger type (automations, named & other triggers) to a different section (keyboard shortcut).

BTT might have been confused and still showed the trigger in the wrong trigger category after pasting, which then led to the other weird behavior.
I‘ll add some checks to prevent that in the future.

Yeah I get it. I'm giving BTT a hard time! :sweat_smile:

Copying from one section to another is really useful though. I wonder if converting the trigger type by re-creating it and merely duplicating the actions themselves would be an easy fix, from a technical perspective. It would certainly make sense from a UX PoV.

Also, I would value a preset integrity check that runs upon startup and checks for existing inconsistencies related to this/reveals ghost triggers. Something seems permanently broken in my configuration, even after I deleted the entire (keyboard) trigger and recreated it from scratch. The same exact actions work fine if placed inside another (keyboard) trigger that is outside the (keyboard) folder that I was messing around in before. That folder has about 30 different (keyboard) triggers so I haven't attempted to move the triggers to another folder and delete the folder itself to see if that fixes it, but like I mentioned before, I've actually done similar things many times before (copying from one section to another) and now I worry about the health of my profile.