Trackpad left and right edges do not register click or tap even though they are tracked in the viewer

Describe the bug
A clear and concise description of what the bug is.

Trackpad left and right edges do not register click or tap even though they are tracked in the viewer. Scrolling with two fingers and moving the mouse is unaffected. Disabling BTT does remedy the problem. So, I know it is being caused by BTT and not another program.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

MacBook Pro 2018 Touch Pad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro (15-inch, 2018)
  • macOS version: Mojave 10.14.2
  • BetterTouchTool version: repeated on 2.671 and 2.667

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Only workaround is to disable BTT. I can't tell if a specific trigger is causing it or not as a conflict.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

No crash.

that's probably thumb detection. It can be turned off in the trackpad preferences in BTT , but in general I recommend to leave it on to prevent false triggers.

Thanks for responding!

I tried turning off thumb detection, but it didn't work. --I even restarted the macbook.

Also, I repeated it on a Magic Track Pad too.

Everything was working fine as I was editing my gestures and then suddenly no clicks or taps would work on the left and right edges --about a cm wide.

wait, what kind of gestures did you configure? (There are some that need to block clicks in order to work)

I was working with 5 finger and 4 finger gestures.

Also, single corners, force corners, triangles
and tip taps.

Does that help?

I'll check later when I'm at my Mac! Corner clicks should only block clicks in the corners.

Maybe go to the about tab in BetterTouchTool and click the "export debug information" button. This will create a folder called BetterTouchToolDebug on your desktop, if you send that to I'll be able to have your exact setup and probably see what's wrong.

Awesome! I just sent it to you. Thank You.

I tried disabling all the corner click and force actions through delete or just adding a modifier. But, none of it made a difference.

Thank you for the debug information, I think I found a bug! Should be fixed with the next alpha version later today.

You're amazing. Thanks for catching it!!!