Trackpad Double click suddenly no longer working after updated to v4.258

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

running v4.258, no alpha updates available, issue continues after restarting computer

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Double click on the Macbook trackpad no longer works in all apps. Disabling BTT in each app or for all apps restores it to working properly. Have not made any settings changes, just updated to the latest version of BTT

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Macbook trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2020 M1 Macbook pro
  • macOS version: 13.5.2
  • BetterTouchTool version: (please post the exact version - not just "the latest one") v 4.258

Additional information (e.g. crash logs, related issues, etc.):

do you maybe have a click or double click trigger configured in the “normal mouse“ section in BTT? (Their behavior might have changed slightly depending on your settings)

yes. removing it fixed the problem. Thanks.

do you remember what exactly you had configured?

I can chime in here - I just ran into the same issue, but on my late 2015 iMac running macOS 12.6.9 and BTT v 4.272 (though when I encountered the issue, I was running an earlier version, likely from about a month or two ago. Forgot to write it down, sorry!).

I use a Kensington Expert Trackball, and in the past have used their software to map the upper buttons to mouse 4 and 5, then used BTT to map those buttons to move a space to the left and right. For the past few years they have added a way to map the buttons to those functions directly, so I no longer needed BTT to help, but had forgotten to remove the old mappings.

I spent a few weeks away my computer with it turned off, but when I returned I could not double click. It appeared that I was unable to click a second time on any spot without moving my mouse first. After updating all my software and messing with Apple's settings to try and fix the issues, I used safemode to help diagnose that BTT was causing the problem. This post helped me figure out how to fix the problem. I am attaching a picture of what my mappings looked like before I deleted them, fixing my problem. Somehow, the mouse 5 trigger to move left a space option got replaced with left click, and was causing the issues. I hope this helps, let me know if there is any other information I didn't think to include that might be useful.