Trackpad and gestures are not properly recognised (Macbook Pro M2)

Describe the bug
BTT is not recognising trackpad gestures. If I downgrade or replace the current UI with the oldest one, there is a message in red saying: "no multitouch capable trackpad found!"

Also, live view doesn't show any interaction with the trackpad (e.g. no single finger tracking, no gestures)

In my opinion, this might be a problem related with this macbook specifically (maybe a small trackpad update which is not being addressed?)

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Pro Trackpad (Macbook Pro 13 M2 2022 (Mac14,7))


Device information:
- Type of Mac: Macbook Pro 13 M2 2022 (Mac14,7)
- macOS version: macOS Monterey 12.4
- BetterTouchTool version: 3.812

This is the last version I've tried which I believe to be the latest Alpha. Also tried the stable release and an old release which is binded to my license. Performed multiple system reboots, cleaning configurations and/or any file found between versions. (using sudo find . 2>/dev/null| grep BetterTouchTool) .

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I was considering acquiring the latest license, I've been a BTT user since 2010 and acquired the first license in order to support this project. Didn't updated it yet cause I was not using any of the new features, but in this new laptop I'll certainly use them.

Sounds bad, could you go to Help => Export Diagnostic Debug Info and send the result to

It could also be that your old license is not working for the new version thus disabling functionality, but I'd need to check the logs to know for sure.

Thanks for the fast reply! I've sent the required debug info via email..

I don't think the problem is related to the license, I've installed BTT using trial license and it didn't worked. Although I knew it was a long shot, I've tried the old license with the solo purpose of downgrading and testing if the old version would work.

Still, I'm considering acquiring the latest version, since touch-bar features are excelent and this new interface look awesome!

Could you check whether giving more permissions in System Preferences => Security & Privacy => Privacy helps? Maybe there have been some changes on these M2 machines:

Possible permissions to try:

  • Accessibility
  • Input Monitoring
  • Full Disk Access

The only one missing from the previous post was "Full Disk Access". After manually adding this specific permission + system reboot still not working.

Sending you debug export again via email if that helps.

Do your standard macOS multitouch gestures work correctly? E.g. four finger swipes to move desktops etc.?

Yes, they are working properly.

I've also disabled them for test purposes, in case of interference which didn't fixed the problem.

I think it might be possible the device definitions have not yet been fully updated in the 12.4 macOS for these new devices. I'll need to check whether I can get my hands on such a device, otherwise we might need to wait for 12.5 to see whether anything changes.

Looks like it is not yet reporting the trackpad to BTT ;-(

Worry not mate! I know this machines were introduced very recently, and might not be the best or the most bought option at the moment. I'll wait some weeks to see if macOS 12.5 resolves the issue and report it back.

Many thanks for the very personal and fast support! Glad to know the main developer is so keen into solving every problem. I'll definitely buy the latest version in order to keep supporting BTT as soon as it is stable for my own machine.

We'll keep in touch!

Thanks for helping test this. I think I'll be able to get one of these in ~2 weeks.

One more question: According to the logs you have a Magic Mouse connected - correct? Would you be able to check whether the live view shows something for the Magic Mouse (after adding at least one gesture)

Hum, I think you are getting close to the culprit. I do have a Magic Mouse (actually I have both versions - battery and lightning versions) but I've never connected it to this specific laptop.

Do you think BTT is identifying the internal trackpad as a Magic Mouse? :thinking:

Edit: yes, that's the problem! If i add any gesture to the Magic Mouse section, gestures work on the trackpad. Amazing!! I think I can import my gestures in this section, as a workaround until the APP works as expected.

Oh that's great, then that should be a relatively simple fix!
The Magic Mouse gestures are not optimized for the large trackpad, thus they might behave incorrectly. It seems like the standard identifiers of Magic Mouse & the new Trackpad overlap - I think I need to look at the detailed id now.

I will post a debug version to gather some more identifiers later today - then I'd need the logs one more time, that should allow me to correctly classify the new trackpad!

Awesome! :smiley:

Take your time and post the debug version when it's ready and I'll help you with clean/fresh logs.

Once again, thank you very much for your help :+1: I've been using BTT for so long (10+ years) and the kind of support we get for this app is huge compared to its price!

ah I forgot to update you: I think this should be fixed in 3.818. I’m now checking an additional property to identify trackpads

Thanks mate! I can confirm it is working properly now. Sorry for the delay in reporting it was fixed, it has been a crazy week :sweat_smile:

Once again, cheers for the amazing support. You got yourself a new customer for the lifetime license!

1 Like