Touchbar Permanent Crash After Updating to 2.683

Describe the bug

After updating to 2.683, BTT touchbar crashes immediately after rebooting and will not relaunch thereafter, not even by restarting BTT.

All other configurations (keyboard, trackpad, mouse, etc) function normally.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Device information:

  • Type of Mac: Macbook Pro 15' 2017
  • macOS version: Mojave 10.14.2
  • BetterTouchTool version: 2.683

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Read your release notes, so I'm tagging you now @Andreas_Hegenberg . Let me know if you need anything. Thank you.

same here - icon is there, but no function, restart and all did not fix this. MacbookPro 13'2017

I hope I have identified the issue and fixed it in 2.684 (if not, it would be great if you'd go to the about tab in BTT and click the "export debug info" button. This will create a folder called BetterTOuchToolDebug that you can send to

looks good so far - thanks

Maybe a "how to uninstall completely tutorial" would be helpful

Updated, but unfortunately the issue is still there.

What I have noticed though is that the TB will be active if BTT preferences is open and frontmost. As soon as I switch focus to another app though, it reverts back to Apple's TB.

I have sent you an email with the debug files.

Just noticed something else that may be useful to you. BTT's TB will show up when opening an app for the first time and getting a window such as this:

@proactivematter is your Touch Bar possibly just hidden? (your preset seems to work fine here).
Could you try to create a keyboard shortcut and assign the "Toggle BetterTouchTool Touch Bar" action?

Tried it just now, but no luck... :confused:

any specific app where it doesn't work, or doesn't it show up at all? I have also uploaded v2.685 but it shouldn't make a difference

I've now taken notice that the problem is in the GLOBAL set - it's in fact the only thing that doesn't show up.

I hadn't noticed before because with the exception of GLOBAL, all other App's TB configurations are enabled via modifiers. But now I've noticed that these modifiers are working perfectly, and that I am only missing GLOBAL.

Sorry if a little confusing - was I clear enough? If not, perhaps I can send you a short video.

Could you try to disable the "hide of nothing to show" option in the BetterTouchTool Touchbar settings? Not sure why it would think there is nothing to show, but maybe that's it.

you are sure you are on version >= 2.684?

OK, so if I disable "Hide if Nothing to Show", then the touchbar shows "You have not yet configured actions in BetterTouchTool". So its not identifying my Global set for some reason.

Yes, I am on 2.684. Will now update to 2.685.

EDIT: Correction, I now understand what is fundamentally happening. The GLOBAL set is only active when I've nothing else configured for the focused app. The reason that the Global TB was showing up when BTT was frontmost was just because I don't have any TB actions configured for BTT.

Basically, the Global set is not being "combined" with other sets.

do you maybe have "hide global actions when app specific actions " enabled in the BetterTouchTool Touchbar settings?

Ahhhh! You got it!

It wasn't enabled before I updated today to 2.683 though - everything had been working fine before that. I didn't know an update could toggle such a setting.

Thanks for the help @Andreas_Hegenberg. Looking forward to the new UI :slightly_smiling_face:

it shouldn't :slight_smile:
maybe there was a bug that caused this setting to be ignored before or something like this.


I have a similar issue.
When I configure a new widget - say the remaining battery widget - it gets added to the Touch Bar just as long as the widget customisation options are open

Once I hit save, the Touch Bar is back to displaying "You have not yet configured
actions in BetterTouchTool

I have verified that "Hide global actions if app specific actions are configured in BTT" isn't selected.

How can I fix this?


Hey @Andreas_Hegenberg, so I figured out what in fact happened before, and what changed in BTTs behavior for the issue to have arisen.

It's going to be a little hard explaining this, but I'll try to make it simple as possible:

  • If you look at my BTT setup, then you'll see that I have a global profile that is common across all apps, but then the apps themselves have a sort of "hidden" unique TB that is accessible by holding down the Command modifier.

  • For some work intensive apps however - like Adobe Lightroom - I do prefer to have the Global TB be replaced by a fully app-dedicated TB layout.

  • BEFORE THE UPDATE, with "Hide global actions" ON this meant that if I added only Modifier based actions to an app, then the Global actions would still show. This also meant that if I added any non-modifier actions, then these would replace Global actions completely.

  • AFTER THE UPDATE, the layouts no longer "mix", meaning that with "Hide global actions" ON, for apps where I had only modifier actions configured, nothing would show for "non-modifiers" (no Global in place of non-modifiers). After turning "Hide global actions" OFF however, now I cannot have app-based non-modifier actions that substitute the Global TB (the inverse happens, now the non-modifier layouts - Global and App based - MIX together).

Anyway... do you get it?

PS: Happy new year!

ah that makes sense. I'll bring back the old behavior soon!

1 Like

Awesome! Thank you :slight_smile:

Working perfectly on 2.687! Thanks again Andreas.