Touch Bar takes way too long to switch to App-specific setup when using CMD+Tab

touch-bar
#1

Describe the bug
When you do CMD+Tab, it takes too long for the Touch Bar to change its setups between applications, sometimes seconds of delay.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar.

Device information:

  • Type of Mac: 2017 15" MacBook Pro 2.9Ghz
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.717 (1027)
0 Likes

#2

would be great if you'd test the latest alpha. There seems to have been a bug in some systems with the previous feedings that could cause this. It should be fixed in the latest alpha version. (get via "check for alpha version updates")

0 Likes

#3

Nope, it doesn't fix it...Now this pretty much happens all the time, now the Touch Bar even refuses to change from application to application until I "refresh" it by pressing CMD or any other modifier. For people who CMD+tab a ton, this doesn't look good. Hope you get to fixing it soon! Great app other than that! You actually made me want to use the Touch Bar.

0 Likes

#4

weird so far the alpha fixed the issue for all other people I talked to. Are you sure you updated? Which version does it show?

0 Likes

#5

It shows the latest alpha version, 2.725 (1035). I'm going to need to find a program that will automatically press any modifier button once I switch applications for a workaround. How can I help you solve this? What do I send you?

0 Likes

#6

I have the same issue on 2.725, no difference when updating to 2.732, really frustrating, it worked great previously. Is there any system information that would help in solving this?

0 Likes

#7

Unfortunately I can't reproduce the issue here. But maybe go to the about tab in BTT and click the "Export Debug Information" button. This will create a folder called BetterTouchToolDebug that you can send to andreas@folivora.ai

//edit actually I think this might be a bug in the latest macOS version not giving accurate app switch information. I think I might have a workaround, would be great if you'd try 2.733

0 Likes

#8

Wow! Super! Updating to 2.733 actually fixed it! Also I wasn't on Mojave, just 10.13.6, but still you managed to fix it somehow. Thanks, this was driving me a little nuts.

0 Likes

#9

Solved for me too using the latest version! :slight_smile: Missed the notifications for this post, and forgot about it until now. Thanks for the help!

0 Likes