Toggle Between Big and Normal Cursor

Running latest non-alpha.. 4.401


When I try to use the action "Toggle Between Big and Normal Cursor" it just makes the cursor bigger and then refuses to return it to the normal size.

Trackpad, Possibly others.

  • MacBook Pro
  • Sonoma 14.3.1
  • BetterTouchTool version: 4.401

As per screenshot, I am attempting to invoke this action by pressing the shift button quickly twice. It partially works as it increases the cursor size but upon double pressing the shift again, does nothing resulting in a permanent large cursor!

Seems to work fine here. Did you possibly quit BTT after the cursor was big?
In that case try to reset it once (either via system settings or via the "Set Cursor Size" action

Interesting. I have not quit BTT in any attempts. I have used the reset cursor size action to reset it back to 100% after it fails - which is each time.

Also, as I mentioned in a previous thread, this function used to just keep making the cursor bigger and bigger rather than toggle in a recent version. With the latest version it just makes it bigger (or smaller) then does nothing. No toggle.


What trigger did you use to test it. Maybe it is the Key Sequence Trigger that is causing the problem?

Weird, I just tried on another system but it is also working ok there.
Maybe you can workaround it by using the "Cycle Through Multiple Actions" meta action, and then use two "Set/Change Cursor Size" actions where one of them is configured to make the cursor big and one to make it small again.

I used the exact same key sequence as you did for testing.

Something is borked here.

So I tried setting a keystroke to do the same task as my key sequence and they both fail after one attempt (no toggle). Interestingly though, if I use one to make the cursor bigger, the other makes it smaller. Also, I am not the only one having this issue as it has been reported by another on here. Are you running an Alpha or 4.401?

That's very weird as both (key sequence & keyboard shortcut) would call the same code in BTT.

Unfortunately it's hard to tell what's wrong. The APIs to change the cursor size are not public, which means also not documented. I have been using them for > 10 years without many problems, but that doesn't mean they might behave in unexpected ways in specific configurations.

I'd recommend to use the "Cycle Through Multiple Actions" action, then use the "Set Cursor Size" action. That one is simpler because it doesn't need to get the original cursor size and doesn't need to keep state. (See bottom of this page Control Action Sequence Flow · GitBook)

Thanks for your help and taking the time. I'll take a look at your suggestions and see how I go. Cheers.

EDIT: Your suggestion worked like a charm. Thanks again.