Timed trigger not working after de-/activating a preset

Hi Andreas,

first of all, thanks for your great work with BTT!

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.
→ Check, tried a lot of stuff. Have an IT background myself.

Describe the bug

  • Timed trigger (e.g. every hour) to execute an Applescript is working when the MacBook is freshly started
  • On device-lock I deactivate the preset holding this trigger and activate the preset again when unlocking (this works fine) (I don't want the script to be executed when screen is locked)
  • After unlocking the screen the preset is active, but the timed triggers are not executing.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

  • MacBook Pro 16" 2019, Core i7

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 16" 2019, Core i7
  • macOS version: Sonoma 14.2.1
  • BetterTouchTool version: 4.375

Additional information (e.g. crash logs, related issues, etc.):

Thanks and Best, Sebastian

Thanks for reporting! I'll have a look.

Sure :+1:
Could you find anything on that? I can of course test some alpha / beta version if this helps.