Time Machine application doesn't process clicks if BTT is running

Describe the bug
With BTT running, my Time Machine application runs when I launch it, but I can't do anything. If I click on any of the red bars on the right, nothing happens. If I click on any of the windows that receed behind the default window, nothing happens. Clicking on the up/down arrows on the screen does nothing. I can only click on "Cancel" and I can use the Escape key to exit the Time Machine application.

If I "Quit BetterTouchTool" from its menu bar item the Time Machine application works correctly, responding to all clicks. If I launch BetterTouch\Tool again, the Time Machine application does not respond to any clicks except the Cancel button, as before.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad, Magic Trackpad, Magic Mouse

Screenshots
Sorry, but I can't get screen shots or screen videos from Time Machine, since it takes over the computer, as far as I know.

Device information:

  • Type of Mac: MacBookPro 13", 2017, Four Thunderbold 3 Ports, 8 GB Memory, 256 GB Internal SSD
  • macOS version: 11.4 Big Sur
  • BetterTouchTool version: 3.670 | 1711

Workaround/Solution
MY SOLUTION: In BTT Preferences, set it to not auto launch. Turn off BTT. Reboot the Mac. Leave BTT not running.

I also had/have Golden Chaos running within BTT. I can't tell if it is still there. I don't understand BTT well enough, I fear, to navigate all the windows/menu items/options/preference.

I apologize, but I can't tell how to get to the Alpha version of BTT and I can't tell how to "upgrade" GC to a latest version, or even see what version I have installed. BTT is at version 3.670 | 1711 as far as I can tell.

Your note says to check that I have the latest Alpha version running, but I don't see how to find that. I tried the About menu item and looked under the Help menu of BTT but didn't find anything about checking for updates. Probably my error?

Incredibly powerful program. Very confusing to me with SO MANY screens of settings and preferences and such. But that is my problem (unwilling to spend the time to learn a complex system like this) not yours.

Great day!

Updating the status of this problem.
i reformatted the TimeMachine volume and did a new (initial) backup. At this point it seems to work, either with or without BTT running. So I cannot replicate the problem and I don't know if the situation was caused by BTT, TimeMachine issues, or some combination. I will continue to monitor the status of TimeMachine, both with and without BTT running.

Imprint | Privacy Policy