Three-finger click doesn't work

Help would be greatly appreciated!

Describe the bug
Three-finger click doesn't do anything. It is recognized in Live View, which (most of the time) identifies the action (CMD-Click), but it has no effect in applications. I have checked the trackpad preferences, and three-finger click is not selected for anything.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

This affects both my Magic Trackpad and my built-in trackpad

Device information:

  • Type of Mac: MacBook Pro ("13-inch, 2018, Four Thunderbolt 3 Ports")
  • macOS version: 10.15.2
  • BetterTouchTool version: 3.275

Seems to work fine here. In what app are you trying to use it? And to trigger what kind of behavior?

In case you have enabled Three Finger Dragging on your system - this causes various incompatibilities with BTT. In that case try to enable the three finger drag optimizations:

I double-checked, and three-finger drag is off. It's set up to trigger CMD-click in all applications, but I've only tried it in Safari and Mail.

In Live View, sometimes it shows "CMD(⌘)+Click" in response to "3 Finger Tap," and other times it just shows the time-stamp, "3 Finger Tap," and the message "Only gestures you have already set up in BTT will be recognized correctly." In any event, the CMD-click action doesn't seem to happen.

When I turn on the HUD Overlay, sometimes it appears, and sometimes it doesn't (even though Live View recognizes "3 Finger Tap")—but again, in any event, the CMD-click action doesn't seem to happen.

What is weird is, when I close the BTT window, I get better results in Safari: Sometimes the HUD appears and CMD-click works! But only sometimes: mostly nothing happens.

If possible go to help => Export diagnostic debug information in the BTT main menu, if you send the result to andreas@folivora.ai I'll have a look!

Okay—sent. Thanks a lot!

Your settings seem to work fine here. In that case I'd recommend to play a bit with these settings to find the perfect values for you:

Also I'd recommend to upgrade to v3.332

Thanks! Changing those settings seems to have fixed it!

Imprint | Privacy Policy