The Version of BTT you are currently using isn't compatible with the version of your data file!


#1
Blog post on https://folivora.ai from Wed, 05 Jul 2017 22:06:03 +0000
This is a companion discussion topic for the original entry at https://folivora.ai/blog/post/12881

#2

Hello,

I need help since I keep receiving this message:
"The Version of BTT you are currently using isn't compatible with the version of your data file!
Older copies of the data files are stored in ~/Library/Application Support/BetterTouchTool.”

I already tried both commands, but neither worked.

Let me know if you need any more information.


#3

As a last resort you can always delete the ~/Library/Application Support/BetterTouchTool folder (make a copy first).
To go to this folder use Finder => Go => Go to folder and enter the exact path including the ~

Best,
Andreas


#4

That worked, thank you! The copy of the ~/Library/Application Support/BetterTouchTool folder is currently on my desktop. Do I need to move it back at all?


#5

No, it would only be useful if you need to restore some previous setup.


#6

I am getting the same error, after updating to version 2.696. Based on my backups, my previous version was 2.428. I hadn't updated in a while because my license expired, but I have purchased a lifetime license now and that is when I updated and started having trouble. I have removed(after copying) all of the files from ~/Library/Application Support/BetterTouchTool and BTT now starts, but I don't have any of my previous config. Is there a way to get that back?


#7

Do you still have the files from that folder?


#8

Yes, I do. I tried putting the last backup files back and starting BTT and it ignored them and created new.


#9

The easiest way is probably to use BTT v2.428 and export your preset using the "Manage Presets" function, then reimport it in the new BTT version.

If you put the backup files in like you just tried, you would need to rename them to match the latest version. What are the names of the latest files you have backupped?


#10

54


#11

Can you try to rename them (while BTT is quit) to

btt_data_store.version_2_696_build_1001-wal
btt_data_store.version_2_696_build_1001-shm
btt_data_store.version_2_696_build_1001

(but keep a backup still)


#12

yeah, sorry that is what i did originally - that screenshot was from my back up location where the files had the original names. Here is a screenshot of the BTT directory with the old files(renamed) and the new ones it creates upon opening. 42


#13

oh, i see you want me to rename to match the new filenames...trying now, just a sec


#14

Awesome...that worked! Thanks!


#15

Perfect! Seems like something went wrong during the initial database migration process but your old files were still fine.