"The file can't be found."

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
When opening BetterTouchTool or waking the MacBook Air M1 from sleep, there is one (or more) alerts stating "The file can't be found.".

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Application Itself

Screenshots
Screen Shot 2022-01-28 at 9.21.49 AM

Device information:

  • Type of Mac: MacBook Air (M1, 2020)
  • macOS version: 12.3 Beta (21E5196i)
  • BetterTouchTool version: 3_737_build_1879

**Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
com.hegenberg.BetterTouchTool 2022-01-26--16-20-39-443.log.zip (103.5 KB)

Pretty sure it is related to the line item "1643334857.959453|SHORT|Launch Shortcuts Events The application “Shortcuts Events.app” could not be launched because it was not found.|"

thanks for reporting, probably this has been renamed/changed on the new beta. I’ll install that beta soon and fix it.

1 Like

Shortcuts

Resolved in macOS Monterey 12.3 Beta

The Shortcuts Events app, which provides scripting functionality for Shortcuts, no longer needs to be opened once before it can be used. The bundle has moved to /System/Library/CoreServices. If an app relies on the location of the bundle, the code needs to be updated to reference the new location. (85249991)

@Andreas_Hegenberg this is from the beta changelog.

1 Like

great, then I can just disable that code on 12.3. Should be working on BTT alpha 3.738! (uploading now, will be available in 10 minutes)

1 Like

Got it and I can confirm it fixed it for me.

Confirmed fixed in 3.738! Thank you so much!

this worked for me as well thank you very much!

bitcoin widget lauch path not accessible,12.3 beta deprecates Python 2.7.

is there a way to suppress this notification? I'm using the setapp-version of btt and I can't install alpha or beta versions

no, but I’ll push the version to setapp soon!

Python 2.7 is not part of macOS anymore but you can install it manually if you need it for some specific widgets.

However for crypto widgets you could also use a little java script and run it using the Java Script widget. Then you don't need any third party dependencies.

Example for Bitcoin and EUR

(async () => {
const coins = ["BTC"];
const currencies = ["EUR"];

async function fetchCrypto(coins, currencies) {
  const fsyms = coins.join(",");
  const tsyms = currencies.join(",");
  const cryptoCompareURL = `https://min-api.cryptocompare.com/data/pricemultifull?fsyms=${fsyms}&tsyms=${tsyms}`;

  const response = await fetch(cryptoCompareURL);
  const json = await response.json();

  const currentPrices = [];

  for (const currency of currencies) {
    for (const coin of coins) {
      currentPrices.push(json["RAW"][coin][currency]["PRICE"] + " " + currency);
    }
  }

  return currentPrices;
}

const resultPrices = await fetchCrypto(coins, currencies);

returnToBTT(resultPrices.join(" | "));


})();

You can change the coin and currency by editing the second & third line of the script

Errors happen. But it's really frustrating when there's no obvious source to what application is causing the error. Is that is something that could easily be fixed? Add something that identifies the error better than just "The file can't be found."? And not just for this particular error. Any error who's source is ambiguous.

This is not a BTT error, it's a change in the macOS beta version and that is generating this error message due to a file which can not be found anymore but was needed by BTT on older versions (and which was available on previous macOS versions).

The alpha version of BTT already prevents the file from being called.

Please do not use beta versions if you don't like broken things :wink: (but I understand this stuff can be frustrating)

@Andreas_Hegenberg what a spectacular response to an issue that is directly related to a change in the OS that is in the first Beta release.

Thanks for your continued care and dedication to what I believe is the most important utility I have on my MacBook.

@Andreas_Hegenberg, can you please push this fix to setapp?

it had been on setapp a long time already (v3.741)

That's the version I'm running, but it doesn't solve the issue for me. I can replicate it every time BTT is started - the alert window shows up saying the file can't be found. Any suggestion on how to diagnose what's causing it?

@Andreas_Hegenberg I can confirm this behavior. I am running the latest 3.756 straight from the download page on the site and it is spamming me with the "file can't be found" error. It happens everytime I open it but also if I put my computer to sleep or whatever I have to get rid of like 30 of them.

I'm not sure but I think this started when I updated to MacOS 12.3

maybe some preset you have is trying to open some file that doesn't exist? The original bug has been fixed quite a while ago. However it has also been caused by other apps, are you sure you are seeing it because of BTT?

Pretty sure, my BTT is fairly simple. I have it showing my dock and showing music and battery. Besides that I have a button to lock the screen and another to mute the volume. Music (spotify) has no issues opening and closing when I force quit it. Everything in my dock is also working fine without the error after reopening. But when I quit BTT and reopen it the message pops up.