The Caps Lock can set as Hyper key but the named trigger for "released without having been used" not working

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

The Caps Lock can set as Hyper key, the Hyper key action works fine, but the named trigger for "released without having been used" not working. Any reason? I tried many times, including clean install MacOS

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

I set that if the hyper key is released without having been used, it should trigger the option+space named-trigger(I set the Alfred shortcut as option+space), but if I only press and release Caps Lock, Alfred not appear, while it appears when I directly press option+space
Don't know why it doesn't work

Device information:

  • Type of Mac: Macbook air M2
  • macOS version: 14.3.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

Thanks for reporting, this should be fixed in v4.403 alpha!

I also have a macbook air M2, and use the almost the same function (BTT is 4.402 though): hyperkey release is a named trigger to press F18 which I set Alfred up to activate with. It works for me:

I do have a consistent bug with this where sometimes a hyper key binding leaks into the Alfred window even though the hyper key was released before Alfred activated: Problems with a "Sticky" hyper key

Thanks, I confirm it is fixed in the latest version (I tried in 4.407)

hi @Andreas_Hegenberg , can we publish the new alpha version as the stable version? The setapp team only uses the stable version in BetterTouchTool which is still 4.401, need new version with this bug fixed :grinning:

yes, if the current alpha proves to be stable it will soon become the new stable version