The application has a corrupted dictionary

Since the latest update, I have encountered an error when attempting to execute an AppleScript directly through BetterTouchTool. However, executing it via Script Editor functions flawlessly.

BetterTouchTool 4.199
MacBook Pro
16“, 2021
Chip Apple M1 Pro
macOS Ventura 13.5.1

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

Thanks for reporting! Should be fixed now.

1 Like

I’m curious what the underlying fix involved.

just fixing a typo in the BTT apple script definition file (sdef).

Interesting… have you seen any errors about element include: XInclude error : could not load file://localhost/System/Library/ScriptingDefinitions/CocoaStandard.sdef, and no fallback was found

Not yet! Is this popping up in your BTT?

Does that file exist on your machine? (/System/Library/ScriptingDefinitions/CocoaStandard.sdef, go there via Finder => Go => Go to Folder)

Sorry! Not in BTT. We’re getting some reports of it with drag and drop from Apple Mail into DEVONthink. Not always, but I’m trying to see what I can find out here in the wild. We have seen the corrupted dictionary message as well.

And indeed the resource exists.

weird error, unfortunately I don't have any experience with using scriptSuite definitions, which you seem to use. (BTT uses the XML based sdef)

Gotcha. Well, thanks for the chat.
BTT rocks btw :slight_smile:

Thank you!
I wouldn't be surprised if this is some new macOS bug related to such scriptSuites. I don't think many apps still use .scriptSuite definitions :slight_smile:

1 Like