The application "BetterTouchTool" is not open anymore

OK I have restarted my MacBook so many times I think I cannot keep doing this whenever I encounter this error.

This usually happens after my wake my MacBook.
BTT seems to be disabled and I can't launch it from the Applications folder.
It just shows this:

Device information:

  • Type of Mac: MacBook Pro 15" (2018)
  • macOS version: 10.14.4
  • BetterTouchTool version: (can't check now cos I can't open it, but I'm sure it is the latest one)

Are there any crashlogs in the macOS console app under "User Reports"?

BTT is not running properly for me today either. My programmed BTT icons no longer load, though I can see the BTT app running. I've restarted the app and the machine to no avail.
Looking at the Console System.log I see this message repeated:

Oct 21 23:57:07 Shawns-MBP-2017 com.apple.xpc.launchd[1] (com.hegenberg.BTTRelaunch.1932[1375]): Service exited due to SIGTERM | sent by BetterTouchTool[1429]

Device Log:
BUG IN CLIENT OF libsqlite3.dylib: database integrity compromised by API violation: vnode unlinked while in use: /Users/sbrezny/Library/Caches/com.hegenberg.BetterTouchTool/Cache.db

//------------------------//
MBP 13" 2017
macOS Catalina 10.15
BTT 3.205 (1381)

these logs are ok.

However possibly try downloading a fresh copy of BTT from folivora.ai. Maybe something is corrupted, this could explain the strange Finder message.

Hello all. As of this morning my BTT app refuses to load as well I simply have the MacOS touchbar features. I checked the settings and it was authorized in Privacy and Security-Accessibility everything was enabled. I tired restarting a few times and as per this thread tried uninstalling and reinstalling the app. I'm not getting any errors. I can see its running, it lets me set configs and such, but nothing actually loads on the touchbar. I'm on 10.15. Any other ideas or info I can provide to remedy this? Its throwing off my work flow. Thanks!

Most likely your Touch Bar is hidden, does BTT say something about that if you click the menubar icon?

In general it’s a good idea to create a keyboard shortcut and assign the predefined action „Toggle Bettertouchtool Touch Bar“ which allows you to easily hide or show it.

Doesn't appear to be hidden. I've never hidden it before.
I took a screenshot of what I see when I click the icon in the menu bar

Have you tried the shortcut? In some cases macOS can hide the bar without telling BTT - in such cases you need to bring it back (either by pressing the BTT icon in the System Control Strip or by using such a custom keyboard shortcut)

In any case it's definitely a different issue to @tmxgkh, because your BetterTouchTool still seems to start up fine :slight_smile:. One other thing to check on Catalina: Make sure in System Preferences => Keyboard "Touch Bar shows App Controls" is selected.

Thanks for the help I'll try those things and maybe a few others and report back.

1 Like

Thanks again for the help. I got it to load. Now I'll need to work on issues I'm experiencing with Goldenchaos preset, but I know thats a different issue. I ended up uninstalling my direct install and installing via the SetApp application that I just started using. Not sure what the difference would be but it seemed to resolve the issue.

Setapp is using different settings file, so probably one of your BTT settings was somehow causing this.
In case you won't continue to use Setapp, you can reset your BTT settings using this terminal command:
defaults delete com.hegenberg.BetterTouchTool (this will not delete your Presets or Triggers configured in BTT, just the settings like checkboxes etc., e.g. in the general Touch Bar settings)


Summary; BTT is working again but not sure why (or why it stopped working for 24 hrs). I am documenting my summary in case it helps anyone else.

Basic problem for me was all of a sudden BTT didn't work right. It would load/run, but none of my icons would appear, just blank on the touchbar. I did toggle the show hidden option to no success. I restarted BTT and the MBP machine multiple times to no success.
I then uninstalled BTT by moving the app to the Trash bin, restarted macOS. Then I reinstalled BTT using the link provided (it was the same version I had previously installed/running), then re-added the Privacy allowance settings as indicated but still nothing worked (no custom touchbar icons loaded) even though BTT was running.
Once I did see briefly my BTT icons load, but then they disappeared after a few seconds. I could repeat this if I restarted BTT, but ultimately after a few seconds the icons in my touchbar disappeared... very strange.
I closed my MBP for the day while at work today, now tonight upon logging in I toggled the unhide menu option, then everything now works again as normal.
I am not sure what in all of this "fixed" the problem, but mainly happy things are working again.
<>

Imprint | Privacy Policy