Taking a snap shot, and edit will cause BTT drawing gesture to not function

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: iMac 2019
  • macOS version: Sonoma
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

As the subject line states, when I take a snap shot, and click the edit button, go to another window or Mac desktop while still in edit mode, BTT drawing gesture will not work until you find the snap shot with open edit process save it or click done in order for BTT drawing gesture function to come back. And sometimes this could cause BTT to either freeze or crash (occasionally)

The problem is that sometimes I have multiple snaps burried down, and don't remember the one with an edit that is not complete.

I don't see why BTT should stop functioning until you finish the edit window and click "Done". Unless there is something I don't see.

Thank you very much for your continuous support.

Additional information (e.g. crash logs, related issues, etc.):