Streamdeck hotkeys not being picked up

I have an Elgato Streamdeck (aka, a bunch of buttons that send keystrokes) and while I can send in a keystroke and have Alfred's keyboard shortcuts respond when I do this with keyboard shortcut setup using BetterTouchTool it doesn't do anything (but the keyboard shortcut works when used on my keyboard). I have tried running the shortcut in both normal mode as well as legacy but with the same effect. I have a working solution with Alfred but I'd prefer to use BetterTouch if possible.

This seems like a bug to me but possibly I'm missing something. In any event, the Elgato Streamdeck is getting quick popular these days so might be good to have a compact answer here on how people can marry the two.

Describe the bug
A clear and concise description of what the bug is.

  • macOS version: 10.15.6
  • BetterTouchTool version: 3.402

I have this problem as well.

I have two Stream Deck hotkey buttons.

One sends the activation hotkey combination for the app HazeOver which receives it just fine.

The second I intend to have trigger a BetterTouchTool action. When I make the hotkey combo "manually" with the keyboard, the BTT action fires just fine. When I press the Stream Deck button that is supposed to send this hotkey combo, BTT does not respond. So I know that my action is configured to fire with the combo I want and to perform the action I want because it does so when invoked manually. However, it won’t trigger from Stream Deck input from a Stream Deck hotkey action configured in precisely the same way as one that will successfully trigger the "native" activation combo for HazeOver…

Also having this issue. Weirdest thing is it worked last night. Stopped working today.

I figured out a way to do it...bit of a PITA...

Anyway use website buttons on the Stream Deck and this: Using HTTP Requests / Webserver · GitBook


Tip right click on trigger in BTT...copy link to activate trigger...change btt:// to http://your_ip:your_port/

1 Like