Stream Deck XL Flickering after update to 4.003

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
After updating to 4.003, my stream deck XL, which is updated to the latest software and firmware, starts to flicker ever 30s. When I quit BetterTouchTool, the flickering stops, so it's definitely some sort of conflict between the two of them

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Stream Deck XL, 6.02 (17735) and Firmware 1.00.010

It's a normal flicker after 30s

Device information:

  • Type of Mac: M1 Max, Macbook Pro 16
  • macOS version: Monterrey 12.6.2
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 4.003 (2218)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
It's unusable the way it is. Had to roll back to 3.952

After rolling back to 3.952, everything is back to normal, so definitely it's a bug on 4.003

Do you use BTT with the Stream Deck? Or do you exclusively use the Stream Deck software?

Nop, exclusively the Stream Deck Software.

In that case try to disable the Stream Deck support in BTT for now:

Ok, this is a solution for now!!! However, I'd look into it, but something in that integration is a bit buggy...

I'm checking right now, but don't see flickering on my devices yet :-/
Did you have any Stream Deck trigger configured in BTT (even if unused)?

I recorded a video on it.. but essentially it is a flicker
It almost feels like the stream deck keeps reloading, so I don't know

I will reinstall the stream deck plugin and also will do some testing here soon.. then I'll report back

BTT checks every 30 seconds whether it can get a connection to the Stream Deck software - if not it tries to relaunch the Stream Deck app. That's probably what's happening to you - because you are not using the BTT integration, it will not get a connection and therefore try to restart the Stream Deck software.

In 4.004 I have added an additional check, so that it only does this if at least one trigger has been added to the Stream Deck section in BTT

Can you support disabling the check when no triggers are defined, or all Stream Deck triggers are disabled?

yes that's already done in 4.004