Stream Deck - Safari Running Indicator

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

  1. I am on the latest (alpha) version of BTT,
  2. I have restarted my system.
  3. I have not encountered a crash

Describe the bug

When using the dock widget and putting the apps I want to display, including Safari, in the "Only show items with these names (separated by commas):" section, the Safari app does not have the Running Indicator correctly display based on the app being open or quit. All the other apps I have tried correctly display if the app is open or not, just not Safari.

A few things I tried to verify this was a Safari-Specific Issue:

  1. Once I set the apps I wanted in the "Only show items with these names (separated by commas):" section, I restarted BTT and they displayed correctly. Safari will display the Running Indicator if Safari is open before I restart the app, but then the indicator will not go away even when the app is quit. Same happens when Safari is closed when I restart BTT, it shows NO Running Indicator and one never appears even when Safari is opened. This happens correctly for all other apps tested.
  2. I verified that I was using the correct name for Safari in the section where I placed the app names. It was correct. I figured so because if I tried a lowercase 's' for Safari, it wouldn't even show up when restarting BTT, but I verified using the Advanced Conditions -> Visible Windows Viewer to identify the app name.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Stream Deck

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 14-inch, 2021 MacBook Pro
  • macOS version: Ventura 13.0.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.939

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):